summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-05 07:25:22 +0100
committerSam James <sam@gentoo.org>2021-10-05 07:26:34 +0100
commit548b44240beafd530c26a2e79a386b8f3c1ccd02 (patch)
treefc88c6287070f943e40bc60ec983cb8518e1b04e
parentdev-ruby/text: add ruby30 (diff)
downloadgentoo-548b4424.tar.gz
gentoo-548b4424.tar.bz2
gentoo-548b4424.zip
dev-ml/ppx_optcomp: add 0.14.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/ppx_optcomp/Manifest1
-rw-r--r--dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_optcomp/Manifest b/dev-ml/ppx_optcomp/Manifest
index 2c8054a9d09c..ba84a1b65683 100644
--- a/dev-ml/ppx_optcomp/Manifest
+++ b/dev-ml/ppx_optcomp/Manifest
@@ -1 +1,2 @@
DIST ppx_optcomp-0.14.0.tar.gz 16583 BLAKE2B 9b139708e02501245d5440a862324fe0191c9c96772e6599ed474a734263c4d2c0fa08fff666abd2efb218ec03a2b9b47c5ef6480d53a8d0f280550b741ac39a SHA512 e86b108d805500cbd7be628f41436ec8de0e8622d4218631d01bf73b0e70da0a057b8531465206baa9b8851ce9c22c5cd53921fccfae352ee46527d69964dc44
+DIST ppx_optcomp-0.14.3.tar.gz 16749 BLAKE2B 3c6dd2b5ac0a10e3d95c6a734ee09b0bef8af6d949c9f31150f1f8ac14ec72bb06455c3bf0c025bc99b939fa86b0d730abd8aefcdbd3998bfc16eef7a6a766bd SHA512 73b53dece639aebe20a8c9eaec50f6f491ac8163d96ceab66169d99f9bb50ed9c40c38731cd6e8543dae97c3a45650733d622e5bd4a2db812000c4694c823157
diff --git a/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild b/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
new file mode 100644
index 000000000000..d01ce62cd244
--- /dev/null
+++ b/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Optional compilation for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_optcomp"
+SRC_URI="https://github.com/janestreet/ppx_optcomp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"