summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-17 07:55:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-17 08:54:25 +0200
commit5496732e10e5f17908f70f7cae3d217c43d99d6c (patch)
tree3a5af2afab36b84ece13edb2403f775680cb4a04
parentdev-python/traitlets: Bump to 5.2.1_p0 (diff)
downloadgentoo-5496732e.tar.gz
gentoo-5496732e.tar.bz2
gentoo-5496732e.zip
dev-python/cerberus: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cerberus/cerberus-1.3.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/cerberus/cerberus-1.3.4-r1.ebuild b/dev-python/cerberus/cerberus-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..995bff25596f
--- /dev/null
+++ b/dev-python/cerberus/cerberus-1.3.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight and extensible data-validation library for Python"
+HOMEPAGE="
+ https://docs.python-cerberus.org/
+ https://github.com/pyeve/cerberus/
+ https://pypi.org/project/Cerberus/
+"
+SRC_URI="
+ https://github.com/pyeve/cerberus/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2_no-pytest-runner.patch
+ "${FILESDIR}"/${PN}-1.3.4-raw_docstrings.patch
+)
+
+# Require currently unpackaged pytest-benchmark, more useful to developers than to end users.
+EPYTEST_DESELECT=(
+ cerberus/benchmarks/
+)
+
+distutils_enable_tests pytest