summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-19 06:19:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-19 06:57:47 +0200
commit549f09b7e3a1f29564972144ad369e0478d5e14d (patch)
tree1315f51592d664f3e649e591db8c0a1a7caaaeea
parentnet-vpn/libreswan: drop 4.7, 4.9, 4.10 (diff)
downloadgentoo-549f09b7.tar.gz
gentoo-549f09b7.tar.bz2
gentoo-549f09b7.zip
dev-python/hypothesis: Bump to 6.79.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.79.1.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index d44af325ceec..716a194a9b9d 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,2 +1,3 @@
DIST hypothesis-6.76.0.gh.tar.gz 9373576 BLAKE2B ed580296f163f9808597aa3a7b2ceaf1ea43431a9049ffdba229dc0f7886c8ee42829c45c98cc8ec0aae7d1f41f455f7ffd818beb1a956498ac4d676cd72b678 SHA512 2e46762a3bcc595c92eb57e65b2c7ef07062df1c393033efd2cb6b3c774ecbbe41f672e7b6c63ca0e8afb732c0f5308dddd6908bc2f43eab5c0713a6d688d5f4
DIST hypothesis-6.79.0.gh.tar.gz 9377619 BLAKE2B 8e0650967f8552b3968f8627ef61119ea1532656009fcc83899d4c1e5e97e71e7cb14ffe0864008f7e6c658cff864a7a6d94d04365aba99d38383e3c1b4941a6 SHA512 d4268503425805d7ce0800434474b0f582d6114c3323b36abf6ce58e9f8530d7c11ab634671670f1d67387ac8c90d198303129c552130c8127dc0b3bbad2c766
+DIST hypothesis-6.79.1.gh.tar.gz 9377826 BLAKE2B 13bf9383df81bf8aa504e4f1314958c98612bd507a935c749411008a25c9c1502cb157f4e80ae43b707486cfa5c4706c13118ea4c62d2cf8d7c40a8a811aba98 SHA512 aa52b85162ddb1fd1da8d01de4e47a5426831791c402fe589090474070608b98e40e8fcda197c18d7b8b4d13004afd0b04fb6f65f965e1af05b41005d3b38618
diff --git a/dev-python/hypothesis/hypothesis-6.79.1.ebuild b/dev-python/hypothesis/hypothesis-6.79.1.ebuild
new file mode 100644
index 000000000000..17591ecbb4e4
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.79.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_12 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_IGNORE=()
+ local EPYTEST_DESELECT=(
+ # these tests can randomly fail with RecursionError when run
+ # in parallel
+ # https://github.com/HypothesisWorks/hypothesis/issues/3671
+ hypothesis-python/tests/cover/test_lookup.py::test_resolving_mutually_recursive_types
+ hypothesis-python/tests/cover/test_lookup.py::test_resolving_mutually_recursive_types_with_defaults
+ )
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}