summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-03 10:00:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-03 12:35:07 +0200
commit54bb03a90e3a6807784751ad74fef93397c4ab9e (patch)
treee2cf8d526434a040a01a81ecce5ec9aa5a90d7a0
parentmedia-libs/libsdl2: ppc64 stable wrt bug #836664 (diff)
downloadgentoo-54bb03a9.tar.gz
gentoo-54bb03a9.tar.bz2
gentoo-54bb03a9.zip
dev-python/nest_asyncio: Bump to 1.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nest_asyncio/Manifest1
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.5.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
index 88dac5f9958c..386471f8a40d 100644
--- a/dev-python/nest_asyncio/Manifest
+++ b/dev-python/nest_asyncio/Manifest
@@ -1 +1,2 @@
DIST nest_asyncio-1.5.4.tar.gz 5893 BLAKE2B d3f693e251d5f0e9f7f31e0aa3e88962aaf927320268a31d53fc2b2eb71bb45eb3a8f9d7f733d0ca96a848beb1d8c505121325749226e962a44b3c2988873190 SHA512 982e274712ec8a8004108492708f28fbf459c5f2d274e754387b0afa0f92425fe29be075e3402bbc319accf17974efcbb3015799421f6a10ed15cfa424f82310
+DIST nest_asyncio-1.5.5.tar.gz 7386 BLAKE2B c5d3704dae962ec82a515e2c056c24bd0fbabcf1cd2347379e1d58fc23c922325c89ed0941aead4dc90e0a94fc39ddb5e38fe4decc6e444b0c1261ae955520cb SHA512 8f28b4495f1d595f5943fb8a40c8894183398865059c42686483d6c4af6634b5119ff6e694b98662bfdd71046ec0bed70f5fcceb67971637c0fed91cb6d6eaea
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.5.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.5.ebuild
new file mode 100644
index 000000000000..9bae0a7c1f05
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.5.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest