summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-08-22 16:52:33 +0200
committerSam James <sam@gentoo.org>2022-08-23 05:51:19 +0100
commit54bb9f516d5608cbf3bb445af98fa8876ce938e9 (patch)
treee0230b477b6b7040d2e2efbe0cf3c5635d753ea5
parentnet-im/bitlbee: remove obsolete xmpp? ( !nss ) requirement (diff)
downloadgentoo-54bb9f51.tar.gz
gentoo-54bb9f51.tar.bz2
gentoo-54bb9f51.zip
net-im/bitlbee: remove system-json-parser patch from live
This feature is now integrated in upstream. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/26925 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild3
-rw-r--r--net-im/bitlbee/files/bitlbee-9999-system-json-parser.patch99
2 files changed, 1 insertions, 101 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index 8d4f88ddc3d1..079feaea767b 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -62,7 +62,6 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}/${PN}-3.5-systemd-user.patch"
- "${FILESDIR}/${P}-system-json-parser.patch"
)
src_configure() {
@@ -115,7 +114,7 @@ src_configure() {
--libdir=/usr/$(get_libdir) \
--pcdir=/usr/$(get_libdir)/pkgconfig \
--plugindir=/usr/$(get_libdir)/bitlbee \
- --externaljsonparser=1 \
+ --external_json_parser=1 \
--systemdsystemunitdir=$(systemd_get_systemunitdir) \
--doc=1 \
--strip=0 \
diff --git a/net-im/bitlbee/files/bitlbee-9999-system-json-parser.patch b/net-im/bitlbee/files/bitlbee-9999-system-json-parser.patch
deleted file mode 100644
index d0020307cfa3..000000000000
--- a/net-im/bitlbee/files/bitlbee-9999-system-json-parser.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-This is adapted patch from upstream PR 151. Original PR defines
---external-json-parser which breaks configuration, see [1]. It was changed to
---externaljsonparser and $external_json_parser to $externaljsonparser.
-Additionally, LDFLAGS_CHECK variable was introduced in order to make
-tests working, see [2] and #865667.
-
-[1] https://github.com/bitlbee/bitlbee/pull/151#issuecomment-1201181905
-[2] https://github.com/bitlbee/bitlbee/pull/151#issuecomment-1219254239
-
-Upstream-PR: https://github.com/bitlbee/bitlbee/pull/151
-
-diff --git a/configure b/configure
-index 2291e9a4..3ba40933 100755
---- a/configure
-+++ b/configure
-@@ -47,6 +47,7 @@ plugins=1
- otr=0
-
- events=glib
-+externaljsonparser=auto
- ssl=auto
-
- pam=0
-@@ -154,6 +155,7 @@ Option Description Default
- --events=... Event handler (glib, libevent) $events
- --ssl=... SSL library to use (gnutls, nss, openssl, auto)
- $ssl
-+--externaljsonparser=0/1/auto Use External JSON parser $externaljsonparser
-
-
- --target=... Cross compilation target same as host
-@@ -404,6 +406,21 @@ else
- fi
- echo 'EVENT_HANDLER=events_'$events'.o' >> Makefile.settings
-
-+if [ "$externaljsonparser" = "auto" ]; then
-+ if pkg-config --exists json-parser; then
-+ externaljsonparser=1
-+ else
-+ externaljsonparser=0
-+ fi
-+fi
-+echo "EXTERNAL_JSON_PARSER=$externaljsonparser" >> Makefile.settings
-+if [ "$externaljsonparser" = "1" ]; then
-+ echo "CFLAGS+=$(pkg-config --cflags json-parser)" >> Makefile.settings
-+ echo "LDFLAGS_BITLBEE+=$(pkg-config --libs json-parser)" >> Makefile.settings
-+ echo "LDFLAGS_CHECK+=$(pkg-config --libs json-parser)" >> Makefile.settings
-+fi
-+
-+
- detect_gnutls()
- {
- if $PKG_CONFIG --exists gnutls; then
-@@ -993,6 +1010,12 @@ else
- echo ' systemd disabled.'
- fi
-
-+if [ "$externaljsonparser" = "1" ]; then
-+ echo ' Using system JSON parser.'
-+else
-+ echo ' Using bundled JSON parser.'
-+fi
-+
- echo ' Using python: '$PYTHON
- echo ' Using event handler: '$events
- echo ' Using SSL library: '$ssl
-diff --git a/lib/Makefile b/lib/Makefile
-index fc46aedc..ad95d9cb 100644
---- a/lib/Makefile
-+++ b/lib/Makefile
-@@ -12,7 +12,11 @@ _SRCDIR_ := $(_SRCDIR_)lib/
- endif
-
- # [SH] Program variables
--objects = arc.o base64.o canohost.o $(EVENT_HANDLER) ftutil.o http_client.o ini.o json.o json_util.o md5.o misc.o oauth.o oauth2.o proxy.o sha1.o $(SSL_CLIENT) url.o xmltree.o ns_parse.o
-+objects = arc.o base64.o canohost.o $(EVENT_HANDLER) ftutil.o http_client.o ini.o json_util.o md5.o misc.o oauth.o oauth2.o proxy.o sha1.o $(SSL_CLIENT) url.o xmltree.o ns_parse.o
-+
-+ifneq ($(EXTERNAL_JSON_PARSER),1)
-+objects += json.o
-+endif
-
- LFLAGS += -r
-
-diff --git a/tests/Makefile b/tests/Makefile
-index 76122a2f..2235bf1d 100644
---- a/tests/Makefile
-+++ b/tests/Makefile
-@@ -20,7 +20,7 @@ test_objs = check.o check_util.o check_nick.o check_md5.o check_arc.o check_irc.
-
- check: $(test_objs) $(addprefix ../, $(main_objs)) ../protocols/protocols.o ../lib/lib.o
- @echo '*' Linking $@
-- $(VERBOSE) $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS) $(EFLAGS)
-+ $(VERBOSE) $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS) $(LDFLAGS_CHECK) $(EFLAGS)
-
- %.o: $(_SRCDIR_)%.c
- @echo '*' Compiling $<
---
-2.35.1
-