summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-25 13:17:45 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-25 13:17:45 +0200
commit54bc8e37d82d1f43b57a42bf00d1c549bdaf33cc (patch)
tree2abed64255488d502c4867739d5e8d3092a7b912
parentdev-java/tomcat-servlet-api: backport 9.0.45 ~ppc64 keyword (diff)
downloadgentoo-54bc8e37.tar.gz
gentoo-54bc8e37.tar.bz2
gentoo-54bc8e37.zip
net-misc/curl: Only run tests under native ABI
Closes: https://bugs.gentoo.org/740206 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-misc/curl/curl-7.76.1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-misc/curl/curl-7.76.1.ebuild b/net-misc/curl/curl-7.76.1.ebuild
index 20741408e3e1..75fede552e18 100644
--- a/net-misc/curl/curl-7.76.1.ebuild
+++ b/net-misc/curl/curl-7.76.1.ebuild
@@ -284,6 +284,10 @@ multilib_src_configure() {
echo "Requires.private: ${priv[*]}" >> libcurl.pc
}
+multilib_src_test() {
+ multilib_is_native_abi && default_src_test
+}
+
multilib_src_install_all() {
einstalldocs
find "${ED}" -type f -name '*.la' -delete || die