summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-27 06:33:11 +0100
committerSam James <sam@gentoo.org>2021-10-27 06:34:04 +0100
commit54bde0319de6703dfee26e6c706f5d443789383b (patch)
tree6dd3a209438346c3c3797241ea8d93cfbad99c2b
parentdev-util/google-perftools: add Fedora TLS patch for arm64 (diff)
downloadgentoo-54bde0319de6703dfee26e6c706f5d443789383b.tar.gz
gentoo-54bde0319de6703dfee26e6c706f5d443789383b.tar.bz2
gentoo-54bde0319de6703dfee26e6c706f5d443789383b.zip
dev-util/google-perftools: drop 2.8, 2.9.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.8.ebuild94
-rw-r--r--dev-util/google-perftools/google-perftools-2.9.1.ebuild95
3 files changed, 0 insertions, 190 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index b28d894d09f6..30a6cf15a61b 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -1,3 +1,2 @@
DIST gperftools-2.7.tar.gz 916854 BLAKE2B d14c2b88f2986d3691d7184e1759de2066ca50224f745a6291ab2ebd5f7f985dec4916a1c01d61142eca9b64f3742c50b82e64118602afaa7b27ae2d94a4ed4d SHA512 4a8e72b960218b0615281b830b3f1a4a1b27830006c45ed68b1ffd152bb50a8b3beec850526e330e2ad08c28774bdc01dade9bcc3e7c9e26d30823cc55648d77
-DIST gperftools-2.8.tar.gz 928379 BLAKE2B e94bac4153cb5d3170d6486a9065b56d631ab261d25b4a5a150f04f87f767c203508839daf400dbe06dc82e9e3da2988e4b4c74725c6be836fa9c70ed0576209 SHA512 c959ffa2b36ecfea10927b40b6dd668385cff7eab3c4bc2d7c5aed5f4de87ce8e4f9b30ab44652a0288badbb6c5aa7110c491b13c4030fb656609c2eb25918a8
DIST gperftools-2.9.1.tar.gz 924910 BLAKE2B fcf0491e42ff4212a63ab0af422f27f5a625c53a0b33e69f8dede96b004a0f01af104d9791a4b75d38145ae0059f5e2967ea1d09b0712cc4d930ef7aafd4f3ba SHA512 5e07f28da9afc5f1ba3df7f06ad0e146c171d33e1779bbaab21547ed234aaced02e5278c1eb8f92fc45480abd2474d6a2d4c71644fb9378f41088c56cc1bc8ab
diff --git a/dev-util/google-perftools/google-perftools-2.8.ebuild b/dev-util/google-perftools/google-perftools-2.8.ebuild
deleted file mode 100644
index b5cb254c7978..000000000000
--- a/dev-util/google-perftools/google-perftools-2.8.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-MY_P="gperftools-${PV}"
-
-inherit toolchain-funcs flag-o-matic autotools vcs-snapshot multilib-minimal
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/archive/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux x86/amd64/ppc/ppc64/arm
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="largepages largepages64k +debug minimal optimisememory test static-libs"
-
-RESTRICT="!test? ( test )"
-
-DEPEND="!ppc64? ( sys-libs/libunwind )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-musl-tests.patch"
-)
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- MAKEOPTS+=" noinst_PROGRAMS= "
-}
-
-src_prepare() {
- default
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- use largepages64k && append-cppflags -DTCMALLOC_LARGE_PAGES64K
- use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug debugalloc) \
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sandbox is enabled."
- ewarn "See https://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- multilib-minimal_src_test
-}
-
-src_install() {
- if ! use minimal && has x32 ${MULTILIB_ABIS}; then
- MULTILIB_WRAPPED_HEADERS=(
- /usr/include/gperftools/heap-checker.h
- /usr/include/gperftools/heap-profiler.h
- /usr/include/gperftools/stacktrace.h
- /usr/include/gperftools/profiler.h
- )
- fi
-
- multilib-minimal_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
- use static-libs || find "${D}" -name '*.la' -delete || die
-}
diff --git a/dev-util/google-perftools/google-perftools-2.9.1.ebuild b/dev-util/google-perftools/google-perftools-2.9.1.ebuild
deleted file mode 100644
index 896b51dfd9c8..000000000000
--- a/dev-util/google-perftools/google-perftools-2.9.1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-MY_P="gperftools-${PV}"
-
-inherit toolchain-funcs flag-o-matic autotools vcs-snapshot multilib-minimal
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/archive/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux amd64/arm/arm64/ppc/ppc64/riscv/x86
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="largepages largepages64k +debug minimal optimisememory test static-libs"
-
-RESTRICT="!test? ( test )"
-
-# TODO: remove the riscv special case once either libunwind has begun supporting this arch
-# or this package allows using llvm-libunwind for other arches
-DEPEND="!ppc64? (
- riscv? ( sys-libs/llvm-libunwind )
- !riscv? ( sys-libs/libunwind )
-)"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- MAKEOPTS+=" noinst_PROGRAMS= "
-}
-
-src_prepare() {
- default
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- use largepages64k && append-cppflags -DTCMALLOC_LARGE_PAGES64K
- use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug debugalloc) \
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sandbox is enabled."
- ewarn "See https://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- multilib-minimal_src_test
-}
-
-src_install() {
- if ! use minimal && has x32 ${MULTILIB_ABIS}; then
- MULTILIB_WRAPPED_HEADERS=(
- /usr/include/gperftools/heap-checker.h
- /usr/include/gperftools/heap-profiler.h
- /usr/include/gperftools/stacktrace.h
- /usr/include/gperftools/profiler.h
- )
- fi
-
- multilib-minimal_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
- use static-libs || find "${D}" -name '*.la' -delete || die
-}