summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-13 05:24:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-13 05:25:37 +0100
commit54c78e476a751206cdf068d6321d64b4a5c3bdc2 (patch)
tree413c4bfaf6298d74a7b1ddb6f999ffe8285cc61b
parentdev-python/zope-configuration: Bump to 5.0.1 (diff)
downloadgentoo-54c78e476a751206cdf068d6321d64b4a5c3bdc2.tar.gz
gentoo-54c78e476a751206cdf068d6321d64b4a5c3bdc2.tar.bz2
gentoo-54c78e476a751206cdf068d6321d64b4a5c3bdc2.zip
dev-python/editorconfig-core-py: Prepare for rename
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3-r1.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3-r1.ebuild b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3-r1.ebuild
index f23f55ddca2f..df3872e19dc0 100644
--- a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3-r1.ebuild
+++ b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3-r1.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit cmake distutils-r1
+MY_P=editorconfig-core-py-${PV}
TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
DESCRIPTION="Clone of EditorConfig core written in Python"
HOMEPAGE="https://editorconfig.org/"
-SRC_URI="https://github.com/${PN%-core-py}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/editorconfig/editorconfig-core-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
test? (
- https://github.com/${PN%-core-py}/${PN%-core-py}-core-test/archive/${TESTVER}.tar.gz -> ${PN%-core-py}-core-test-${TESTVER}.tar.gz
- )"
+ https://github.com/editorconfig/editorconfig-core-test/archive/${TESTVER}.tar.gz
+ -> editorconfig-core-test-${TESTVER}.tar.gz
+ )
+"
LICENSE="PYTHON BSD-4"
SLOT="0"
@@ -20,12 +25,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="cli test"
RESTRICT="!test? ( test )"
-RDEPEND="!<app-vim/editorconfig-vim-0.3.3-r1
- cli? ( !app-text/editorconfig-core-c[cli] )"
+RDEPEND="
+ !<app-vim/editorconfig-vim-0.3.3-r1
+ cli? ( !app-text/editorconfig-core-c[cli] )
+"
src_prepare() {
if use test; then
- mv "${WORKDIR}"/${PN%-core-py}-core-test-${TESTVER}/* "${S}"/tests || die
+ mv "${WORKDIR}"/editorconfig-core-test-${TESTVER}/* "${S}"/tests || die
fi
if ! use cli; then
sed -i -e '/editorconfig\.__main__/d' setup.py || die