summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMyckel Habets <gentoo-bugs@habets-dobben.nl>2022-07-19 09:32:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-07-19 13:43:50 +0300
commit54ea5246931a0275959be163480e9e1e5987a83f (patch)
treee7621b55df23cfa37d404e98300475f20dbee3e3
parentwww-client/seamonkey: add seamonkey-2.53.13 (diff)
downloadgentoo-54ea5246931a0275959be163480e9e1e5987a83f.tar.gz
gentoo-54ea5246931a0275959be163480e9e1e5987a83f.tar.bz2
gentoo-54ea5246931a0275959be163480e9e1e5987a83f.zip
www-client/seamonkey: enhancements to 2.53.13
- eclass/mozcoreconf-v6.eclass: Change LANG and LC_* exports from "C" to "C.UTF-8" due to ascii/unicode-related build issues with seamonkey's build system. - eclass/mozcoreconf-v6.eclass: Work around lack of --disable-elf-hack handling on PPC64. - Drop crypt USE flag, due to retirement of x11-plugins/enigmail. - Drop debug USE flag, due to being unused and broken in upstream. Signed-off-by: Myckel Habets <gentoo-bugs@habets-dobben.nl> Closes: https://github.com/gentoo/gentoo/pull/26472 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--eclass/mozcoreconf-v6.eclass15
-rw-r--r--www-client/seamonkey/seamonkey-2.53.13.ebuild41
2 files changed, 19 insertions, 37 deletions
diff --git a/eclass/mozcoreconf-v6.eclass b/eclass/mozcoreconf-v6.eclass
index 8cea230a959c..2d94be6baee4 100644
--- a/eclass/mozcoreconf-v6.eclass
+++ b/eclass/mozcoreconf-v6.eclass
@@ -78,10 +78,10 @@ mozconfig_use_with() {
moz_pkgsetup() {
# Ensure we use C locale when building
- export LANG="C"
- export LC_ALL="C"
- export LC_MESSAGES="C"
- export LC_CTYPE="C"
+ export LANG="C.UTF-8"
+ export LC_ALL="C.UTF-8"
+ export LC_MESSAGES="C.UTF-8"
+ export LC_CTYPE="C.UTF-8"
# Ensure we use correct toolchain
export HOST_CC="$(tc-getBUILD_CC)"
@@ -195,8 +195,13 @@ mozconfig_init() {
# Strip optimization so it does not end up in compile string
filter-flags '-O*'
+ # elf-hack is broken on x86 and disabled by default.
if is-flagq '-g*' ; then
- mozconfig_annotate 'elf-hack broken with -g* flags' --disable-elf-hack
+ case "${ARCH}" in
+ amd64 | arm)
+ mozconfig_annotate 'elf-hack is broken with -g* flags' --disable-elf-hack
+ ;;
+ esac
fi
# Strip over-aggressive CFLAGS
diff --git a/www-client/seamonkey/seamonkey-2.53.13.ebuild b/www-client/seamonkey/seamonkey-2.53.13.ebuild
index 9dc3cd2e2ba8..efeab5f7dcaa 100644
--- a/www-client/seamonkey/seamonkey-2.53.13.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.13.ebuild
@@ -45,7 +45,7 @@ HOMEPAGE="https://www.seamonkey-project.org/"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
SLOT="0"
SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,png,sqlite} )
-IUSE="+chatzilla cpu_flags_arm_neon +crypt dbus debug +gmp-autoupdate +ipc jack
+IUSE="+chatzilla cpu_flags_arm_neon dbus +gmp-autoupdate +ipc jack
lto pulseaudio selinux startup-notification test webrtc wifi"
IUSE+=" ${SYSTEM_IUSE[@]}"
KEYWORDS="~amd64 ~ppc64 ~x86"
@@ -96,7 +96,6 @@ COMMON_DEPEND="
>=sys-apps/dbus-0.60
)
jack? ( virtual/jack )
- crypt? ( <x11-plugins/enigmail-2.1.0 )
kernel_linux? ( !pulseaudio? ( media-libs/alsa-lib ) )
pulseaudio? ( || (
media-sound/pulseaudio
@@ -116,7 +115,7 @@ COMMON_DEPEND="
system-libevent? ( >=dev-libs/libevent-2.0:0= )
system-libvpx? ( >=media-libs/libvpx-1.8.0:0=[postproc] )
system-png? ( >=media-libs/libpng-1.6.31:0=[apng] )
- system-sqlite? ( >=dev-db/sqlite-3.38.2:3[secure-delete,debug=] )
+ system-sqlite? ( >=dev-db/sqlite-3.38.2:3[secure-delete] )
wifi? (
kernel_linux? (
>=dev-libs/dbus-glib-0.72
@@ -147,21 +146,12 @@ pkg_setup() {
ewarn "Those belong to upstream: https://bugzilla.mozilla.org"
fi
- if use crypt ; then
- ewarn
- ewarn "Enigmail has dropped support for Seamonkey in early 2019. If you are still"
- ewarn "using it, consider yourself lucky, but also consider to start migrating away"
- ewarn "from it. The crypt USE flag and its x11-plugins/enigmail dependency will be"
- ewarn "removed in the near future."
- ewarn
- fi
-
moz_pkgsetup
}
pkg_pretend() {
# Ensure we have enough disk space to compile
- if use debug || use lto || use test ; then
+ if use lto || use test ; then
CHECKREQS_DISK_BUILD="16G"
else
CHECKREQS_DISK_BUILD="12G"
@@ -171,7 +161,7 @@ pkg_pretend() {
spkg_setup() {
# Ensure we have enough disk space to compile
- if use debug || use lto || use test ; then
+ if use lto || use test ; then
CHECKREQS_DISK_BUILD="16G"
else
CHECKREQS_DISK_BUILD="12G"
@@ -201,20 +191,9 @@ src_prepare() {
use system-libvpx && eapply -p2 "${WORKDIR}"/gentoo-${PN}-patches-${PV}/USE_flag/1009_seamonkey-2.53.3-system_libvpx-1.8.patch
- # Fix for non-intel architectures, for now only ppc64. See bug 836319
- if use ppc64; then
- use webrtc && eapply -p2 "${WORKDIR}"/gentoo-${PN}-patches-${PV}/USE_flag/1012_seamonkey-2.53.11.1-ppc64_webrtc_skip_sse2.patch
- fi
-
# Allow user to apply any additional patches without modifing ebuild
eapply_user
- # Enable gnomebreakpad
- if use debug ; then
- sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
- build/unix/run-mozilla.sh || die
- fi
-
# Ensure that are plugins dir is enabled as default
sed -i -e "s:/usr/$(get_libdir)/mozilla/plugins:/usr/$(get_libdir)/${PN}/plugins:" \
xpcom/io/nsAppFileLocationProvider.cpp || die
@@ -268,6 +247,9 @@ src_configure() {
# Must pass release in order to properly select linker via gold useflag
mozconfig_annotate 'Enable by Gentoo' --enable-release
+ # Broken on PPC64, but outdated and should not be used according to upstream.
+ mozconfig_annotate 'Outdated and broken, disabled' --disable-jemalloc
+
# Must pass --enable-gold if using ld.gold
if tc-ld-is-gold ; then
mozconfig_annotate 'tc-ld-is-gold=true' --enable-gold
@@ -278,13 +260,8 @@ src_configure() {
# Enable position independent executables
mozconfig_annotate 'enabled by Gentoo' --enable-pie
- mozconfig_use_enable debug
- mozconfig_use_enable debug tests
- if use debug ; then
- mozconfig_annotate 'enabled by Gentoo' --enable-debug-symbols
- else
- mozconfig_annotate 'disabled by Gentoo' --disable-debug-symbols
- fi
+ # Debug is broken, disable debug symbols
+ mozconfig_annotate 'disabled by Gentoo' --disable-debug-symbols
mozconfig_use_enable startup-notification