summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2022-02-02 18:13:42 +0100
committerDaniel Pielmeier <billie@gentoo.org>2022-02-02 18:13:42 +0100
commit54ee03cd18b1d146bb733fcde488cb748c2d3dca (patch)
tree1112719632c4c5848f56d5efe44e6c8845ca85a6
parentapp-portage/pfl: Migrate to PEP517 build. (diff)
downloadgentoo-54ee03cd.tar.gz
gentoo-54ee03cd.tar.bz2
gentoo-54ee03cd.zip
app-portage/pfl: Remove old.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
-rw-r--r--app-portage/pfl/pfl-3.2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-portage/pfl/pfl-3.2.ebuild b/app-portage/pfl/pfl-3.2.ebuild
deleted file mode 100644
index c7efacdcd5c1..000000000000
--- a/app-portage/pfl/pfl-3.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="xml"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Searchable online file/package database for Gentoo"
-HOMEPAGE="http://www.portagefilelist.de https://github.com/portagefilelist/client"
-SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+network-cron"
-
-DEPEND=""
-RDEPEND="
- ${DEPEND}
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- sys-apps/portage[${PYTHON_USEDEP}]
- network-cron? ( sys-apps/util-linux[caps] )
-"
-
-S="${WORKDIR}/client-${PV}"
-
-python_install_all() {
- if use network-cron ; then
- exeinto /etc/cron.weekly
- doexe cron/pfl
- fi
-
- systemd_dounit systemd/pfl.{service,timer}
-
- keepdir /var/lib/${PN}
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
- touch "${EROOT}/var/lib/${PN}/pfl.info" || die
- fi
- chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
- chmod 775 "${EROOT}/var/lib/${PN}" || die
-}