summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-29 21:41:38 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-29 21:46:09 +0200
commit550de61ab83a660bb28ec96144fe490c13cea064 (patch)
treea3f064df07b96655353742ca8ce67e0ec37a433f
parentkde-plasma/breeze: drop 5.26.3.1 (diff)
downloadgentoo-550de61a.tar.gz
gentoo-550de61a.tar.bz2
gentoo-550de61a.zip
dev-python/pkginfo: add 1.9.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pkginfo/Manifest1
-rw-r--r--dev-python/pkginfo/pkginfo-1.9.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index ed104b7ab701..a2e5e5a27ee6 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1 +1,2 @@
DIST pkginfo-1.8.3.tar.gz 375734 BLAKE2B a3e9779bcb7cd326d8bd8137fa388055032fd4ee7732d47a341807201a97f1d44652d8e46adefd301cf7cd3c1d041e49a6ed2b8752e12347a8a2a2349cf397bd SHA512 54a67bdf078b38600651cb94afa62e9d86fce512022b1e79eb4565289ae3fad2325647654704488968e18cd85cbba4bd0ce28392fd09ae9638ee449e802273eb
+DIST pkginfo-1.9.0.tar.gz 376601 BLAKE2B 1823140bcd109cf2549f0c7f8db4315880a86030a8400838755664794a7cac94998a6a20832db6b29d5f8623fc16d0bed477eb48750184ba04b6440063d6bf02 SHA512 5189929a80aedbeb65ad3b243d6f916854887e34d3489eab71a6ca69ab82d0fb2cc62ec7a49999890eb323be981d35505a6f47d2debc83cfa1cc8bb04523dcb0
diff --git a/dev-python/pkginfo/pkginfo-1.9.0.ebuild b/dev-python/pkginfo/pkginfo-1.9.0.ebuild
new file mode 100644
index 000000000000..263179ac56d4
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # fail because of extra python 2.7 classifier
+ pkginfo/tests/test_utils.py::Test_get_metadata::test_w_module_and_metadata_version
+ pkginfo/tests/test_utils.py::Test_get_metadata::test_w_package_name_and_metadata_version
+)