summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-03 08:58:39 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-03 08:58:54 -0400
commit5511b0a8bf767be61d967245455a0ffd617d27ac (patch)
tree944143b2fcc398ca145027ef4b48acfd7359fda5
parentdev-util/mdds: No need to set --docdir with EAPI-6. (diff)
downloadgentoo-5511b0a8.tar.gz
gentoo-5511b0a8.tar.bz2
gentoo-5511b0a8.zip
dev-python/pypy: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/pypy/pypy-4.0.1.ebuild5
-rw-r--r--dev-python/pypy/pypy-5.0.0.ebuild5
-rw-r--r--dev-python/pypy/pypy-9999.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/pypy/pypy-4.0.1.ebuild b/dev-python/pypy/pypy-4.0.1.ebuild
index a6c918a540f0..69c51e4563f1 100644
--- a/dev-python/pypy/pypy-4.0.1.ebuild
+++ b/dev-python/pypy/pypy-4.0.1.ebuild
@@ -17,13 +17,14 @@ SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${P}-src.tar.bz2
LICENSE="MIT"
SLOT="0/$(get_version_component_range 1-2 ${PV})"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc gdbm +jit low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
virtual/libintl:0=
dev-libs/expat:0=
- dev-libs/openssl:0=[-bindist]
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
bzip2? ( app-arch/bzip2:0= )
gdbm? ( sys-libs/gdbm:0= )
ncurses? ( sys-libs/ncurses:0= )
diff --git a/dev-python/pypy/pypy-5.0.0.ebuild b/dev-python/pypy/pypy-5.0.0.ebuild
index a6c918a540f0..69c51e4563f1 100644
--- a/dev-python/pypy/pypy-5.0.0.ebuild
+++ b/dev-python/pypy/pypy-5.0.0.ebuild
@@ -17,13 +17,14 @@ SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${P}-src.tar.bz2
LICENSE="MIT"
SLOT="0/$(get_version_component_range 1-2 ${PV})"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc gdbm +jit low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
virtual/libintl:0=
dev-libs/expat:0=
- dev-libs/openssl:0=[-bindist]
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
bzip2? ( app-arch/bzip2:0= )
gdbm? ( sys-libs/gdbm:0= )
ncurses? ( sys-libs/ncurses:0= )
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index 07df84769194..73a3d5309d9c 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -18,13 +18,14 @@ SRC_URI="
LICENSE="MIT"
SLOT="0/$(get_version_component_range 1-2 ${PV})"
KEYWORDS=""
-IUSE="bzip2 doc gdbm +jit low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
+IUSE="bzip2 doc gdbm +jit libressl low-memory ncurses sandbox +shadowstack sqlite cpu_flags_x86_sse2 test tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
virtual/libintl:0=
dev-libs/expat:0=
- dev-libs/openssl:0=[-bindist]
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
bzip2? ( app-arch/bzip2:0= )
gdbm? ( sys-libs/gdbm:0= )
ncurses? ( sys-libs/ncurses:0= )