summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 20:22:50 +0000
committerSam James <sam@gentoo.org>2020-08-02 20:22:50 +0000
commit5517e066e9f017502f2e6e5585e39d08bc9073fb (patch)
tree7d32a27f21292220028928ba41c19ace8c2099e8
parentpackage.mask: last-rite app-misc/evemu (diff)
downloadgentoo-5517e066.tar.gz
gentoo-5517e066.tar.bz2
gentoo-5517e066.zip
dev-python/sentry-sdk: bump to 0.16.3
We can't yet add tests because of unpackaged dependencies: executing, fakeredis. In turn, they require some unpackaged dependencies too, and this doesn't seem worth it at this point in time. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index c5a35dd737b7..67e98ca4d7c0 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1 +1,2 @@
DIST sentry-sdk-0.14.4.tar.gz 75420 BLAKE2B cbc5f401fae8a4a9eaa8f6fff8ca16a61cf2d339f14787610646112f67d7b0694d95a6076d2810968d28eb176d447fec6cf49af9a317bb2c30b4e6ab2d89a4f0 SHA512 66886df71a3d8f9f86f41bfc4078bf80f217bcb0a27fb9e93acee193b482d3045db44953f6f0b4d05e79daa91dadb56c2784b13d1308e7bc00fb40f485537dab
+DIST sentry-sdk-0.16.3.tar.gz 170145 BLAKE2B bf619313fb3f49800f5384f0dfec3aa34ef4bb030c5e038a485a8861a733a537ee7c834c8c200a2244335c3c61e7d564005b81d4e5c5f603d2864b2a943a5384 SHA512 e8589f7bd433d4aff068099e860c0cf012fc88dc63806873573a338bb91848d73e0a2af76dad0a5e023a1b25b0be85507346b77dec5c5a265942005219541699
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild
new file mode 100644
index 000000000000..c8ddaf21a30c
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://getsentry.com https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+
+# No tests for now
+# Need unpackaged: executing, fakeredis