summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-12 09:19:10 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-12 09:25:28 +0200
commit552174708806d60ac9dc15359a54c5b3d3e436d1 (patch)
tree2a643860f51b2f543d983aebc82692fa62e8b070
parentx11-libs/c++-gtk-utils: Old (diff)
downloadgentoo-552174708806d60ac9dc15359a54c5b3d3e436d1.tar.gz
gentoo-552174708806d60ac9dc15359a54c5b3d3e436d1.tar.bz2
gentoo-552174708806d60ac9dc15359a54c5b3d3e436d1.zip
x11-misc/xfe: Version 1.43.2
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--x11-misc/xfe/Manifest1
-rw-r--r--x11-misc/xfe/xfe-1.43.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index ee51ae02fe3d..2138944642f3 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1,3 +1,4 @@
DIST xfe-1.42.tar.gz 2727833 BLAKE2B fbca14c77b04cb367173907dd4ae9c210cd88768276e5b7391338b29dc988288f866419f57d1189db6235941e4e2f91608835351000a42d46ed3e7c4c236c69f SHA512 858dd761e45ff09d32d2a230304be0817eab4b6a772376b08d778bb8e1eef681228e5d88e53c441f9b8722d8b7eeae96980e30f8c5e8bb603d4d9a3b3d267351
DIST xfe-1.43.1.tar.gz 2776237 BLAKE2B fc82e2ea21643ecc3875512538af24daddb0db0e8829ce23c7589dc90d68e896282f70d771dcf885ea746acfa88adbb7abe6a0c354e74afa5f722dcfacf77350 SHA512 3c697ff5d0246c8bab86c9824dd4a3475ed3775d2933c63eb8e78f02b4455edb4ca98f86123eac77f611eee6ad660bf0a909c4c2791af19506a4f1744395008e
+DIST xfe-1.43.2.tar.gz 2834576 BLAKE2B 5ac7ebf229febb75a99e4829a38a3675d6674ec6eced13dc5be70d2b68ce88f6394621dffec2d8359e72da7eace582883b72491e90597ab4a8925685cb577fcb SHA512 ad7b450d0828747f801219c23824b0751fc2a7f0eea791369c4adb3090ffe1279056fa8804ef97b25a2f810e00d37357efc962dc9d4087c3d7cc5f8ffb37d51d
DIST xfe-1.43.tar.gz 2775098 BLAKE2B 41a9d36da0bd2c58de8c928daf5714c90cd24952934ba22550651a7e6829b4f3386fd7ef89c93907eb2b28f2c7086ced1c8b5282b00beaa3ad79c9443f12e5b2 SHA512 e1b8e2d1509de913ceb76d05c7480842ae7c5389df2f02d39c1f80bd7387ce6ff77e82a95f0f1853a976e27ceb5380024337e261621ea3233996d2dec48f82a3
diff --git a/x11-misc/xfe/xfe-1.43.2.ebuild b/x11-misc/xfe/xfe-1.43.2.ebuild
new file mode 100644
index 000000000000..57333f1ae0f0
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.43.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit l10n xdg-utils
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[png,truetype]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}