summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-01-27 17:32:11 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-01-27 17:33:12 -0500
commit5524ddb7021e80934133b87551e593ac377014b2 (patch)
tree73ee4ad66c9825e78dcd7653ab13531c678cab0c
parentsys-devel/prelink: fix USE=doc failure, bug #578948 (diff)
downloadgentoo-5524ddb7.tar.gz
gentoo-5524ddb7.tar.bz2
gentoo-5524ddb7.zip
Revert "dev-python/setuptools: bump to 40.7.0"
This reverts commit aa1d23476375ca12f3afc702c2aaa20e2fe73952. Bug: https://bugs.gentoo.org/676608 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-40.7.0.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 6d9de140b554..52e5469e8d7e 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,2 @@
DIST setuptools-36.7.2.zip 726758 BLAKE2B 8821d3142f2149fbdea4d231052c3990fa7a14c57c421309683c6a65102ce4911850acd5d492087aa0f14a0026da732e47eb9bf971030443fc1b57f9f909aaaa SHA512 746dce135dbacb65565787a20a2611388605e2371c94f0f8803e7712e515e69c270751d16a21f381bf6e8ddc0a1b39494db7d0c67bb32e6230a90c5d517e78f9
DIST setuptools-40.6.3.zip 839328 BLAKE2B ddc87213439ce2ad96ba54218bd5b3e41a7c31d670bddb9e4ea058b8ee7dffbe6fcb0e5fd24baf3fb38f5e824fde36aa8dc1e09d7ac37f9375ee351406389cd6 SHA512 6c628b8fc67645bca96ddcd016ec9a685e91690bf98dff077e842cfbd0d8d24de76ac51b3ff238d31551a48819d8f694fee6e9bb422ca954e54c22b4bda0038c
-DIST setuptools-40.7.0.zip 841969 BLAKE2B 45129918f20b440f84969db0e94fc183d91cbf3c80aed220e00fa4c5d57fdfbcc4c83ec0ee52533df98d9a318d0936c1e0a4ffd5a47c5977c3ae5ed8f4b1fb96 SHA512 a360461f70222f1de859a8920d8f8e1257eb47f25a481c0d4a3435f74dc5aef4fd2e2fab5285173777483b1b23e7e203617073d753461373ad1c4768e5ce8aba
diff --git a/dev-python/setuptools/setuptools-40.7.0.ebuild b/dev-python/setuptools/setuptools-40.7.0.ebuild
deleted file mode 100644
index d67bd927712b..000000000000
--- a/dev-python/setuptools/setuptools-40.7.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Collection of extensions to Distutils"
-HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
- <dev-python/pytest-4
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- )
-"
-PDEPEND="
- >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
-
-# Force in-source build because build system modifies sources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
-
-python_prepare_all() {
- if [[ ${PV} == "9999" ]]; then
- python_setup
- ${EPYTHON} bootstrap.py || die
- fi
-
- # disable tests requiring a network connection
- rm setuptools/tests/test_packageindex.py || die
-
- # don't run integration tests
- rm setuptools/tests/test_integration.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
- # It tries to sandbox the test in a tempdir
- HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
- distutils-r1_python_install
-}