summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-31 07:31:38 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-31 08:44:46 -0500
commit5528dc3412aecdd8734cd5dfc1bad47110b8510d (patch)
treedcf590754c800ac89f2ec9d6bfdbd58add6464f6
parentx11-terms/kitty-shell-integration: add 0.27.0 (diff)
downloadgentoo-5528dc34.tar.gz
gentoo-5528dc34.tar.bz2
gentoo-5528dc34.zip
x11-terms/kitty-terminfo: add 0.27.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 16dd9be0cb92..1611ede2ced2 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1 +1,2 @@
DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
+DIST kitty-0.27.0.tar.xz 5067860 BLAKE2B 5c9126dd9e76afcd6d53aa025adc36912145129b16b0db60c9cb12736df895166d417cbce9198e1feddd3f07c216e557136a130853fa0ddd91833c67fe236c4e SHA512 8063008df261747a7089c69ad9ae3a3d3c24286014f02d04faee9f0b5b6f452172cf99ff8a520ca8e314ba0009e0009701292656db913c23d84b6a2311085813
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild
new file mode 100644
index 000000000000..f29634123585
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}