summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-26 03:16:28 +0100
committerSam James <sam@gentoo.org>2023-04-26 03:16:28 +0100
commit5542212403a33d8c2a2c8087b47e4fa1a2b4a267 (patch)
tree131b88e3376a37e5f7e5fbf2e11c2bfbba79877b
parentx11-libs/pango: workaround -Werror=array-bounds issue w/ GCC 13 (diff)
downloadgentoo-5542212403a33d8c2a2c8087b47e4fa1a2b4a267.tar.gz
gentoo-5542212403a33d8c2a2c8087b47e4fa1a2b4a267.tar.bz2
gentoo-5542212403a33d8c2a2c8087b47e4fa1a2b4a267.zip
dev-php/swoole: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895232 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-php/swoole/files/swoole-4.8.7-gcc13.patch19
-rw-r--r--dev-php/swoole/swoole-4.8.7.ebuild6
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-php/swoole/files/swoole-4.8.7-gcc13.patch b/dev-php/swoole/files/swoole-4.8.7-gcc13.patch
new file mode 100644
index 000000000000..a99088af87cf
--- /dev/null
+++ b/dev-php/swoole/files/swoole-4.8.7-gcc13.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/895232
+https://github.com/swoole/swoole-src/issues/4983
+https://github.com/swoole/swoole-src/commit/402eec43ec385b63307b3ba772f871f0f86fa299
+
+From 402eec43ec385b63307b3ba772f871f0f86fa299 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Sun, 19 Feb 2023 13:00:01 +0100
+Subject: [PATCH] Fix #4983 Add missing header for GCC 13 (#4985)
+
+--- a/include/swoole_proxy.h
++++ b/include/swoole_proxy.h
+@@ -17,6 +17,7 @@
+ #pragma once
+
+ #include <string>
++#include <cstdint>
+
+ #define SW_SOCKS5_VERSION_CODE 0x05
+
diff --git a/dev-php/swoole/swoole-4.8.7.ebuild b/dev-php/swoole/swoole-4.8.7.ebuild
index 74dd612ea9a3..843f0db71a41 100644
--- a/dev-php/swoole/swoole-4.8.7.ebuild
+++ b/dev-php/swoole/swoole-4.8.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -41,6 +41,10 @@ RDEPEND="${DEPEND}"
IUSE="debug http2 mysql sockets ssl"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc13.patch
+)
+
src_configure() {
# JEMalloc not included as it refuses to find a ${ESYSROOT}/usr/includes/jemalloc subdirectory
local PHP_EXT_ECONF_ARGS=(