summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 17:49:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:31:18 +0100
commit5567152dca265bc888aa14531bccff727ae19904 (patch)
tree13874f4de42cdf0602fdb7648182b62e400e890c
parentmedia-plugins/gimp-resynthesizer: Switch to PYTHON_SINGLE_USEDEP (diff)
downloadgentoo-5567152d.tar.gz
gentoo-5567152d.tar.bz2
gentoo-5567152d.zip
media-plugins/mythplugins: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-plugins/mythplugins/mythplugins-30.0-r1.ebuild (renamed from media-plugins/mythplugins/mythplugins-30.0.ebuild)16
1 files changed, 10 insertions, 6 deletions
diff --git a/media-plugins/mythplugins/mythplugins-30.0.ebuild b/media-plugins/mythplugins/mythplugins-30.0-r1.ebuild
index b574a2449e66..c8dc9edb4fb1 100644
--- a/media-plugins/mythplugins/mythplugins-30.0.ebuild
+++ b/media-plugins/mythplugins/mythplugins-30.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -56,7 +56,9 @@ DEPEND="
=media-tv/mythtv-${PV}*[alsa?,cdda?,cdr?,exif?,fftw?,ieee1394?,libass?,opengl?,python,raw?,xml?,xvid]
mytharchive? (
app-cdr/dvd+rw-tools
- dev-python/pillow[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ ')
media-video/dvdauthor
media-video/mjpegtools[png]
media-video/transcode
@@ -84,10 +86,12 @@ DEPEND="
)
)
mythnetvision? (
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mysql-python[${PYTHON_USEDEP}]
- dev-python/oauth[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pycurl[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/oauth[${PYTHON_MULTI_USEDEP}]
+ ')
)
mythweather? (
dev-perl/Date-Manip