summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-02-17 13:16:51 -0500
committerBrian Evans <grknight@gentoo.org>2022-02-17 13:58:37 -0500
commit5569cbd7da5f00673ecd6378a92cd8e4f2f9aca9 (patch)
tree8b4f73e7118958ee7301235b1b972c4ef693ed9d
parentdev-php/sebastian-environment: Drop old (diff)
downloadgentoo-5569cbd7.tar.gz
gentoo-5569cbd7.tar.bz2
gentoo-5569cbd7.zip
dev-php/theseer-tokenizer: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/theseer-tokenizer/Manifest2
-rw-r--r--dev-php/theseer-tokenizer/files/autoload.php20
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild36
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild36
4 files changed, 0 insertions, 94 deletions
diff --git a/dev-php/theseer-tokenizer/Manifest b/dev-php/theseer-tokenizer/Manifest
index 82ec38ee8d33..97b386f74765 100644
--- a/dev-php/theseer-tokenizer/Manifest
+++ b/dev-php/theseer-tokenizer/Manifest
@@ -1,4 +1,2 @@
-DIST theseer-tokenizer-1.1.0.tar.gz 10163 BLAKE2B b2360f901d60f784db2045912707a8e293a55967d60d4e72168a1c4b0c9a2d5bdb739fbed9bfec02075476e7bf6762eb1cc7e36870b84fcc341b609527579ca2 SHA512 8b500565dc0d6c8513db3aa72a7ee1fa04510a712ce9b0977feccddc6b2dae53825e39182d43508e196f326776115789e81697116418f6f9f63d08f0c05d0543
-DIST theseer-tokenizer-1.1.3.tar.gz 10553 BLAKE2B 4bed1623abe110cec432a97fbd28752618420a188b450c935c77b5771d6986be9a51c8f100fd81a89d892b0c1e2b46b0124e3c35e3cbe2138eee2d520c74933a SHA512 e29fd41b311bac8021f4c0593d79a9c1bde4b6ccf4774e94d27a0e8a97bac3844109f9312c4aab6e239365630394b602b56a084c291dc13fb439dc8ac22944e3
DIST theseer-tokenizer-1.2.0.tar.gz 7156 BLAKE2B 61474e3ebed5262b4d250f0057fbe68df6b2b2d6026cba28efbfc35c865bc9491e3b3f7871591a7aa52383c3bb748cf5dfb95f36d680bdbb9755b585b5b8f4f8 SHA512 e0deeffc151a1831cc7226037c75b534aa0d28d9639de45a1f0a6f5865d3df3cfbd7225e075b094603d512b0beb449e91205f40366ef1c7c865c8994e0710ff7
DIST theseer-tokenizer-1.2.1.tar.gz 7537 BLAKE2B 204b39ca71cb6e99696c8bda19e5319e83302cd9fd4689343d3864ec81996d433ea8cfa2578abec2bef440271a1abe3169c3c871fd931c1ab73705cb7c36e4eb SHA512 7c7382f8f2e96984862d187fffb08b020cac8c0a0d93b58f9b1a244a46f8fcbfbe1c18d005acce8f8e1ef9aec2b9be99b7f2312e28f54a66f5a97ee263ed5239
diff --git a/dev-php/theseer-tokenizer/files/autoload.php b/dev-php/theseer-tokenizer/files/autoload.php
deleted file mode 100644
index 67f5bd3506e0..000000000000
--- a/dev-php/theseer-tokenizer/files/autoload.php
+++ /dev/null
@@ -1,20 +0,0 @@
-<?php
-/* Autoloader for dev-php/theseer-tokenizer */
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once 'Fedora/Autoloader/autoload.php';
-}
-
-\Fedora\Autoloader\Autoload::addClassMap(
- [
- 'theseer\\tokenizer\\exception' => '/Exception.php',
- 'theseer\\tokenizer\\namespaceuri' => '/NamespaceUri.php',
- 'theseer\\tokenizer\\namespaceuriexception' => '/NamespaceUriException.php',
- 'theseer\\tokenizer\\token' => '/Token.php',
- 'theseer\\tokenizer\\tokencollection' => '/TokenCollection.php',
- 'theseer\\tokenizer\\tokencollectionexception' => '/TokenCollectionException.php',
- 'theseer\\tokenizer\\tokenizer' => '/Tokenizer.php',
- 'theseer\\tokenizer\\xmlserializer' => '/XMLSerializer.php',
- ],
- __DIR__
-);
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
deleted file mode 100644
index f55bd6c3895a..000000000000
--- a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
-HOMEPAGE="https://github.com/theseer/tokenizer"
-SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/tokenizer-${PV}"
-
-RDEPEND="dev-php/fedora-autoloader
- >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
-
-DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
-
-src_prepare() {
- cp "${FILESDIR}/autoload.php" src/ || die
- default
-}
-
-src_install() {
- insinto /usr/share/php/TheSeer/Tokenizer
- doins src/*.php
- dodoc README.md
-}
-
-src_test() {
- phpunit || die "Unit testing failed!"
-}
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
deleted file mode 100644
index 88e27eb644ac..000000000000
--- a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
-HOMEPAGE="https://github.com/theseer/tokenizer"
-SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/tokenizer-${PV}"
-
-RDEPEND="dev-php/fedora-autoloader
- >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
-
-DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
-
-src_prepare() {
- cp "${FILESDIR}/autoload.php" src/ || die
- default
-}
-
-src_install() {
- insinto /usr/share/php/TheSeer/Tokenizer
- doins src/*.php
- dodoc README.md
-}
-
-src_test() {
- phpunit || die "Unit testing failed!"
-}