summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-09 06:27:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-09 06:29:16 +0200
commit557171468d9031b930cb01caafdf40304c3dddc1 (patch)
tree4fcdf76ec3015d915a2ee7495dce54be149c56a7
parentx11-terms/xterm: Stabilize 384 x86, #915450 (diff)
downloadgentoo-557171468d9031b930cb01caafdf40304c3dddc1.tar.gz
gentoo-557171468d9031b930cb01caafdf40304c3dddc1.tar.bz2
gentoo-557171468d9031b930cb01caafdf40304c3dddc1.zip
dev-python/pip-run: Bump to 12.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-12.4.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 4a03525c74e8..9d8085c59924 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -3,3 +3,4 @@ DIST pip-run-12.1.0.tar.gz 34387 BLAKE2B 306dce020589a0cdcaddc70baf75a41621c72a4
DIST pip-run-12.2.0.tar.gz 36557 BLAKE2B a711b984895937546b066accf6e51213ddce2c5a7fff77fd018d3588054968fd3b1560f343f98474944302fe12629272ba1fe374c97b5ab8b6ca4694d4b05081 SHA512 a49a94f163a1344d289d53402b41ba31dceab360040e936a3129a7ac7f8c85eb71d4da5a37e517c8a626e6beac2a3265e617b8e63050f0e952bc94969b3dc6ee
DIST pip-run-12.2.2.tar.gz 37657 BLAKE2B ec4c4452e5721b084e6ad175e044a2e414d5885e60b1e85492dd4df458d1fddf044fa02b50a79678564296d2ea8ccc09c021d922d840342bb215f3c737405425 SHA512 0416a58f91a76982ca5473a4253d592ddfb3a40234a1641bc2f7cc53b3809cb015a47ea64597b4186824cc2cd0029647f2af2b152025757626a9b80ca3b62737
DIST pip-run-12.3.1.tar.gz 37698 BLAKE2B ff16e49bc45e6f24ce33b49dad5b23930aa4148d73751b786e7cb5776773ccc7f740b5c45b90ec1f93d8ab22f6f9683367be38c67245c6f1323f1a075492a2ea SHA512 ccacd12cb7ff929ae89f3cef867e3ed3a800bd91121f5d34b2c5f9ee31c1e1b1b6bd8e910d63abe388439c0e0ee9960fcfc33dbd21cf755f2903d6817d2a53ac
+DIST pip-run-12.4.0.tar.gz 37749 BLAKE2B 76e6708cbcb9329b42ac031ee8f2253f04f898a8d6c83ae687f3a7f6e13f33076fdadad641562f379a5cdad1386cb71bf1b40f494c484f86286d1188f86c04ad SHA512 4e6709b2e22b49a3486f4d1caa07ae3d664b09bf76c9338ef8c9fb80024700fcd58c135d3cf3b69e7fcbf1ce20c996436fa87be03fbe9f5801b274ff72a4a790
diff --git a/dev-python/pip-run/pip-run-12.4.0.ebuild b/dev-python/pip-run/pip-run-12.4.0.ebuild
new file mode 100644
index 000000000000..5cc2fbb52d69
--- /dev/null
+++ b/dev-python/pip-run/pip-run-12.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-env[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_scripts.py
+ )
+ fi
+
+ epytest -m "not network"
+}