summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-11-02 11:11:26 +0100
committerAgostino Sarubbo <ago@gentoo.org>2023-11-02 11:11:26 +0100
commit55a052c6d1b7d17882a72095d7d5815465718ab3 (patch)
treeb71b1dd873fa1c6636a9e76441c3fa61d6559e41
parentapp-misc/fastfetch: drop 2.1.2 (diff)
downloadgentoo-55a052c6d1b7d17882a72095d7d5815465718ab3.tar.gz
gentoo-55a052c6d1b7d17882a72095d7d5815465718ab3.tar.bz2
gentoo-55a052c6d1b7d17882a72095d7d5815465718ab3.zip
app-admin/exo: version bump to 1.74.4
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.74.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index e74a50513ad2..2e96bd080315 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.74.2.gh.tar.gz 10880667 BLAKE2B 501209b7435638fe7d9c769de3e7d32be8d2b83c94b420dbefde21c3afe74e0df42f1ed8d7b6449788524fd80ff69a4886a984ea82b325d8786128f7eae718dc SHA512 753841d3c7b26d0f9c7cfda4ceb4d8604c422d8709ce007ce3f3a867e9fb1148955f0e629a02e791955cfc28a122b43c2734389a57b3b5f6098d2e632e335963
+DIST exo-1.74.4.gh.tar.gz 10883511 BLAKE2B 1ef5a5afa1c84e6639a173ab2107c4fa2b78e9ea23c1030a3efa33573db30fdbf3cde123541ba4753bc463f51ab06c7a71200ddab5e37ffda271a1911e89bba0 SHA512 640746bd58617a5de00c6c3bac9429269589e0613d72f33d9a48ece14b34aedf43c92669b3635710322f84cfb3b469d7e426ed0c00c5018517dbe3d2f90b5d0b
diff --git a/app-admin/exo/exo-1.74.4.ebuild b/app-admin/exo/exo-1.74.4.ebuild
new file mode 100644
index 000000000000..aee98d607c89
--- /dev/null
+++ b/app-admin/exo/exo-1.74.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit=" || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}