summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-28 18:19:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-28 18:53:07 +0200
commit55b7e82e90ab9290f16c980dde5194bb0b7a7702 (patch)
tree9ee1d56e29d9e873c89db407b40026a59a51e01e
parentdev-python/oslo-config: Bump to 9.2.0 (diff)
downloadgentoo-55b7e82e90ab9290f16c980dde5194bb0b7a7702.tar.gz
gentoo-55b7e82e90ab9290f16c980dde5194bb0b7a7702.tar.bz2
gentoo-55b7e82e90ab9290f16c980dde5194bb0b7a7702.zip
dev-python/oslo-concurrency: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-5.2.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 524e59d199d8..43f188acc845 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-5.1.1.tar.gz 59787 BLAKE2B 630e5bef3a4a49d0f7b8b7f79643ef5f737248ec45de0e801107142b898a252fe7c67be6e0f6db4b968e5a163a47d63bc5f756c592d4f729f62c24aa9aeca172 SHA512 2eac13529f1635d39b5866d20d1f077ddcb2a676e78f4f50abe1df13c2fbf9f85aea1b360fde01e983459dcdc4958783477a87eb8fad106362e81e0f77b36561
+DIST oslo.concurrency-5.2.0.tar.gz 60052 BLAKE2B 9f45af8beaa5fc145963e3e12818325dff2a00178c3154a4cf7ce2950ca90d9771be590593cc195c2909930416501da1042768da9ba653c0126437bb518a338e SHA512 9f645aa611882e1b7218a7fbf65b54fef523d9cf067f894e9441c0a8de3ab80495ec8a167604412385edf12fc7a53b73ac0ef63e977889db7021dd5b93b0d72f
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-5.2.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-5.2.0.ebuild
new file mode 100644
index 000000000000..632157759d9d
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-5.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency/
+ https://pypi.org/project/oslo.concurrency/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails, then hangs
+ rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}