summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-05 12:36:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-05 14:54:18 +0100
commit55d36e6c00a983651970661cd37205defd8536ce (patch)
tree96a369c5ecbecd083b7549411f301c68a0b71af1
parentdev-qt/qtcore: Bump to QT5_KDEPATCHSET_REV=5 (diff)
downloadgentoo-55d36e6c.tar.gz
gentoo-55d36e6c.tar.bz2
gentoo-55d36e6c.zip
dev-qt/qtcore: drop 5.15.8-r2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtcore/files/qtcore-5.15.8-fix-crash-w-debug.patch41
-rw-r--r--dev-qt/qtcore/qtcore-5.15.8-r2.ebuild125
2 files changed, 0 insertions, 166 deletions
diff --git a/dev-qt/qtcore/files/qtcore-5.15.8-fix-crash-w-debug.patch b/dev-qt/qtcore/files/qtcore-5.15.8-fix-crash-w-debug.patch
deleted file mode 100644
index 74f5ed5c4886..000000000000
--- a/dev-qt/qtcore/files/qtcore-5.15.8-fix-crash-w-debug.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 0c0b34badb8a56f5c0d7d43c3847508774c8e553 Mon Sep 17 00:00:00 2001
-From: Harald Sitter <sitter@kde.org>
-Date: Mon, 2 Jan 2023 12:38:02 +0100
-Subject: [PATCH] correctly set up ref counting in
- QThreadPool::tryStart(std::function)
-
-this function was inconsistent with the QThreadPool::tryStart(QRunnable)
-overload, where ref counting does get set up correctly. the lack of ref
-counting setup would later cause trouble because we assert the ref
-counting state all over QThreadPool. to prevent failed assertions we
-correctly set up ref counting now.
-
-this change is not applicable to Qt6 because the ref counting has
-already been removed there:
-https://github.com/qt/qtbase/commit/ecfda98d1f91c6a7da0d89826558d856cd88e670
-
-BUG: 449688
----
- src/corelib/thread/qthreadpool.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/corelib/thread/qthreadpool.cpp b/src/corelib/thread/qthreadpool.cpp
-index 40cc646519..8aa06a4c8f 100644
---- a/src/corelib/thread/qthreadpool.cpp
-+++ b/src/corelib/thread/qthreadpool.cpp
-@@ -602,8 +602,12 @@ bool QThreadPool::tryStart(std::function<void()> functionToRun)
- return false;
-
- QRunnable *runnable = QRunnable::create(std::move(functionToRun));
-+ Q_ASSERT(runnable->ref == 0);
-+ ++runnable->ref;
- if (d->tryStart(runnable))
- return true;
-+ --runnable->ref;
-+ Q_ASSERT(runnable->ref == 0);
- delete runnable;
- return false;
- }
---
-GitLab
-
diff --git a/dev-qt/qtcore/qtcore-5.15.8-r2.ebuild b/dev-qt/qtcore/qtcore-5.15.8-r2.ebuild
deleted file mode 100644
index 5817a2b70616..000000000000
--- a/dev-qt/qtcore/qtcore-5.15.8-r2.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} != *9999* ]]; then
- QT5_KDEPATCHSET_REV=3
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-QT5_MODULE="qtbase"
-inherit linux-info flag-o-matic toolchain-funcs qt5-build
-
-DESCRIPTION="Cross-platform application development framework"
-SLOT=5/${QT5_PV}
-
-IUSE="icu old-kernel systemd"
-
-DEPEND="
- dev-libs/double-conversion:=
- dev-libs/glib:2
- dev-libs/libpcre2[pcre16,unicode]
- sys-libs/zlib:=
- icu? ( dev-libs/icu:= )
- !icu? ( virtual/libiconv )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/bootstrap
- src/tools/moc
- src/tools/rcc
- src/corelib
- src/tools/qlalr
- doc
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- !:network
- !:sql
- !:testlib
- !:xml
-)
-
-PATCHES=( "${FILESDIR}/${P}-fix-crash-w-debug.patch" ) # bug 889160, pending upstream
-
-pkg_pretend() {
- use kernel_linux || return
- get_running_version
- if kernel_is -lt 4 11 && ! use old-kernel; then
- ewarn "The running kernel is older than 4.11. USE=old-kernel is needed for"
- ewarn "dev-qt/qtcore to function on this kernel properly. Bugs #669994, #672856"
- fi
-}
-
-src_prepare() {
- # don't add -O3 to CXXFLAGS, bug 549140
- sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/corelib/corelib.pro || die
-
- # fix missing qt_version_tag symbol w/ LTO, bug 674382
- sed -i -e 's/^gcc:ltcg/gcc/' src/corelib/global/global.pri || die
-
- # Broken with FORTIFY_SOURCE=3
- # Our toolchain sets F_S=2 by default w/ >= -O2, so we need
- # to unset F_S first, then explicitly set 2, to negate any default
- # and anything set by the user if they're choosing 3 (or if they've
- # modified GCC to set 3).
- #
- # Refs:
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105078
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105709
- # https://bugreports.qt.io/browse/QTBUG-103782
- # bug #847145
- if is-flagq '-O[23]' || is-flagq '-Ofast' ; then
- # We can't unconditionally do this b/c we fortify needs
- # some level of optimisation.
- filter-flags -D_FORTIFY_SOURCE=3
- # (Qt doesn't seem to respect CPPFLAGS?)
- append-flags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
- fi
-
- # Leads to miscompiled qtcore, bug #865339
- tc-is-clang && append-flags -fno-stack-clash-protection
-
- qt5-build_src_prepare
-
- # workaround for 0148-Annotate-QMutex-...patch adding a header
- perl bin/syncqt.pl -version ${PV} || die
-}
-
-src_configure() {
- local myconf=(
- $(qt_use icu)
- $(qt_use !icu iconv)
- $(qt_use systemd journald)
- )
- use old-kernel && myconf+=(
- -no-feature-renameat2 # needs Linux 3.16, bug 669994
- -no-feature-getentropy # needs Linux 3.17, bug 669994
- -no-feature-statx # needs Linux 4.11, bug 672856
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
- qt5_symlink_binary_to_path qmake 5
-
- local flags=(
- DBUS FREETYPE IMAGEFORMAT_JPEG IMAGEFORMAT_PNG
- OPENGL OPENSSL SSL WIDGETS
- )
-
- for flag in ${flags[@]}; do
- cat >> "${D}"/${QT5_HEADERDIR}/QtCore/qconfig.h <<- _EOF_ || die
-
- #if defined(QT_NO_${flag}) && defined(QT_${flag})
- # undef QT_NO_${flag}
- #elif !defined(QT_NO_${flag}) && !defined(QT_${flag})
- # define QT_NO_${flag}
- #endif
- _EOF_
- done
-}