summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-01-31 16:11:53 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-01-31 16:15:34 +0100
commit55d493463c20191e900f1b1fcd7fb19a809e3938 (patch)
treebb1c57b953da1dc12427cdf3f444ee6d28634096
parentdev-util/intel-graphics-compiler: add 1.0.12812.26 (diff)
downloadgentoo-55d493463c20191e900f1b1fcd7fb19a809e3938.tar.gz
gentoo-55d493463c20191e900f1b1fcd7fb19a809e3938.tar.bz2
gentoo-55d493463c20191e900f1b1fcd7fb19a809e3938.zip
dev-libs/intel-compute-runtime: add 22.49.25018.24
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/files/intel-compute-runtime-22.49.25018.24-level-zero-1.9.patch22
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.49.25018.24.ebuild82
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index b0218b59ad7a..2e9434168059 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1 +1,2 @@
DIST intel-compute-runtime-22.43.24595.35.tar.gz 5880869 BLAKE2B c9d4a16e9908427b69154a5a6550e4eec47bcce4fa811a9121c54de75bcd3e17e1d4cff8b1fa7486b2ffe0dd01f7fae06e5fd3b1d241378dcf521d1f8822bedb SHA512 0aab6cc16f7d523819c9a9eb58fba916c3b06c4be450c94cfc30b36038c768d6ddb79937ded7d9df68b7bdc97679756450c1c54844caed1655ddc688a6ae8a54
+DIST intel-compute-runtime-22.49.25018.24.tar.gz 5991968 BLAKE2B 06589bd63d3cfe35ed0a1af3a94c9e12cc2588143dcf52a371b71f827ca006989a74edabb58b6ecc0a08cfa850f582e47e441ee8d9bffdf672653e8a7809375e SHA512 9c0cc541cd635063ed49e8f807c0a81035abd46367deb43fe7187c00c017f2609cd9c5e55d0b40bb3cb54d05f01306df3a843f3b35683b0ab732881b5192182f
diff --git a/dev-libs/intel-compute-runtime/files/intel-compute-runtime-22.49.25018.24-level-zero-1.9.patch b/dev-libs/intel-compute-runtime/files/intel-compute-runtime-22.49.25018.24-level-zero-1.9.patch
new file mode 100644
index 000000000000..7527117ca032
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/files/intel-compute-runtime-22.49.25018.24-level-zero-1.9.patch
@@ -0,0 +1,22 @@
+--- a/level_zero/core/test/unit_tests/sources/fabric/test_fabric.cpp
++++ b/level_zero/core/test/unit_tests/sources/fabric/test_fabric.cpp
+@@ -110,7 +110,7 @@
+ const ze_pci_ext_properties_t &pciProperties) {
+ EXPECT_TRUE(0 == std::memcmp(vertexProperties.uuid.id, deviceProperties.uuid.id, sizeof(vertexProperties.uuid.id)));
+ if (deviceProperties.flags & ZE_DEVICE_PROPERTY_FLAG_SUBDEVICE) {
+- EXPECT_EQ(vertexProperties.type, ZE_FABRIC_VERTEX_EXP_TYPE_SUBEVICE);
++ EXPECT_EQ(vertexProperties.type, ZE_FABRIC_VERTEX_EXP_TYPE_SUBDEVICE);
+ } else {
+ EXPECT_EQ(vertexProperties.type, ZE_FABRIC_VERTEX_EXP_TYPE_DEVICE);
+ }
+--- a/level_zero/core/source/fabric/fabric.cpp
++++ b/level_zero/core/source/fabric/fabric.cpp
+@@ -56,7 +56,7 @@
+ memcpy_s(fabricVertex->properties.uuid.id, ZE_MAX_UUID_SIZE, deviceProperties.uuid.id, ZE_MAX_DEVICE_UUID_SIZE);
+
+ if (deviceProperties.flags & ZE_DEVICE_PROPERTY_FLAG_SUBDEVICE) {
+- fabricVertex->properties.type = ZE_FABRIC_VERTEX_EXP_TYPE_SUBEVICE;
++ fabricVertex->properties.type = ZE_FABRIC_VERTEX_EXP_TYPE_SUBDEVICE;
+ } else {
+ fabricVertex->properties.type = ZE_FABRIC_VERTEX_EXP_TYPE_DEVICE;
+ }
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.49.25018.24.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.49.25018.24.ebuild
new file mode 100644
index 000000000000..0af0d80dab75
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.49.25018.24.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.1.7:="
+
+DEPEND="
+ ${DEPEND}
+ >=dev-libs/intel-metrics-library-0_pre20220930:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.12812.26
+ >=dev-util/intel-graphics-system-controller-0.8.7:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.9.4:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
+ "${FILESDIR}/${PN}-22.49.25018.24-level-zero-1.9.patch"
+)
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}