summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-01 23:42:18 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-01 23:42:18 +0100
commit55f6eaf540bb9e79985f4753984cfba4498e04c2 (patch)
tree107a208030d79832a1bb98f7215b2831d4dadcee
parentapp-office/abiword: Upper bound on e-d-s (diff)
downloadgentoo-55f6eaf5.tar.gz
gentoo-55f6eaf5.tar.bz2
gentoo-55f6eaf5.zip
app-office/abiword: Bump to 3.0.4
* Include backported patch for enchant-2 Closes: https://bugs.gentoo.org/708362 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-office/abiword/Manifest1
-rw-r--r--app-office/abiword/abiword-3.0.4.ebuild141
-rw-r--r--app-office/abiword/files/abiword-3.0.4-enchant-2.patch54
3 files changed, 196 insertions, 0 deletions
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index ea8763123dbb..565c7fbc0ced 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,2 +1,3 @@
DIST abiword-3.0.2-patchset.tar.xz 11976 BLAKE2B 72acb4956543843ad445525d1f5654c63f2544933aab35a95f0ed4f49e1385c06a29a3deb5b7ba09343188e9adf8f916f0223ab6c2a037424732f5e5bffba103 SHA512 afe6f791f167b40c2fdd16f2308add67990dd1fd0856f5a96e8f486a0af2e7b67cbcde29beacd2d869508e8f98bd3fb140240480882bcd9689cbb1fba6a75743
DIST abiword-3.0.2.tar.gz 11154333 BLAKE2B af49570ad766b0e698313a4a88f14b2370a0a230866c4e8672f56780705060dba4207d4e13358cc290fb3c1a4a6a56efa05fed1f0540f10f7572d8e717e6cd20 SHA512 29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3
+DIST abiword-3.0.4.tar.gz 11064305 BLAKE2B fda1732df0bf78f8830c5d68be18f2aec7f88b8d5bb4fe0effc31b48f03d9195a4337087154ba707a70d80bfcff38f92d7298e7b281afe2eacf000eca8dac9c4 SHA512 121708e010cef6722cab5622dc762f2f92c46e43b65b90b881b4f25ff32c1696fa2d281a3a6f2c04d5b9231bbbd0040281e9d4d7e594ec0ace6caae9c9021ec4
diff --git a/app-office/abiword/abiword-3.0.4.ebuild b/app-office/abiword/abiword-3.0.4.ebuild
new file mode 100644
index 000000000000..034816aedc53
--- /dev/null
+++ b/app-office/abiword/abiword-3.0.4.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~x86 ~amd64-linux ~x86-linux"
+IUSE="calendar collab cups debug eds +goffice grammar +introspection latex map math ots +plugins readline redland spell wordperfect wmf thesaurus"
+# You need 'plugins' enabled if want to enable the extra plugins
+REQUIRED_USE="!plugins? ( !collab !grammar !latex !math !ots !readline !thesaurus !wordperfect !wmf )"
+
+RDEPEND="
+ >=app-text/wv-1.2
+ >=dev-libs/fribidi-0.10.4
+ >=dev-libs/glib-2.16:2
+ >=dev-libs/libgcrypt-1.4.5:0=
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.16:2
+ >=gnome-extra/libgsf-1.14.18:=
+ >=media-libs/libpng-1.2:0=
+ virtual/jpeg:0
+ >=x11-libs/cairo-1.10
+ >=x11-libs/gtk+-3.0.8:3[cups?]
+ calendar? ( >=dev-libs/libical-0.46:= )
+ eds? ( >=gnome-extra/evolution-data-server-3.6.0:= )
+ goffice? ( >=x11-libs/goffice-0.10.2:0.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.0.0:= )
+ map? ( >=media-libs/libchamplain-0.12:0.12 )
+ plugins? (
+ collab? (
+ >=dev-libs/libxml2-2.4:2
+ >=net-libs/loudmouth-1
+ net-libs/libsoup:2.4
+ net-libs/gnutls:=
+ )
+ grammar? ( >=dev-libs/link-grammar-4.2.1 )
+ math? ( >=x11-libs/gtkmathview-0.7.5 )
+ ots? ( >=app-text/ots-0.5-r1 )
+ readline? ( sys-libs/readline:0= )
+ thesaurus? ( >=app-text/aiksaurus-1.2[gtk] )
+ wordperfect? (
+ app-text/libwpd:0.10
+ app-text/libwpg:0.3
+ )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ )
+ redland? (
+ >=dev-libs/redland-1.0.10
+ >=dev-libs/rasqal-0.9.17
+ )
+ spell? ( app-text/enchant:2 )
+ !<app-office/abiword-plugins-2.8"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ collab? ( dev-cpp/asio )"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig"
+
+PATCHES=(
+ # Backport of hard dep on enchant-2
+ # https://gitlab.gnome.org/World/AbiWord/commit/ae05e92df5a5d6151641622c83d35a6fdba47b1f
+ "${FILESDIR}"/${P}-enchant-2.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local plugins=()
+
+ if use plugins; then
+ # Plugins depending on libgsf
+ plugins+=(t602 docbook clarisworks wml kword hancom openwriter pdf
+ loadbindings mswrite garble pdb applix opendocument sdw xslfo)
+
+ # Plugins depending on librsvg
+ plugins+=(svg)
+
+ # Plugins not depending on anything
+ plugins+=(gimp bmp freetranslation iscii s5 babelfish opml eml wikipedia
+ gdict passepartout google presentation urldict hrtext mif openxml)
+
+ # inter7eps: eps.h
+ # libtidy: gsf + tidy.h
+ # paint: windows only ?
+ use collab && plugins+=(collab)
+ use goffice && plugins+=(goffice)
+ use latex && plugins+=(latex)
+ use math && plugins+=(mathview)
+ use ots && plugins+=(ots)
+ # psion: >=psiconv-0.9.4
+ use readline && plugins+=(command)
+ use thesaurus && plugins+=(aiksaurus)
+ use wmf && plugins+=(wmf)
+ # wordperfect: >=wpd-0.9 >=wpg-0.2
+ use wordperfect && plugins+=(wpg)
+ fi
+
+ econf \
+ --disable-maintainer-mode \
+ --enable-plugins="${plugins[*]}" \
+ --disable-static \
+ --disable-default-plugins \
+ --disable-builtin-plugins \
+ --disable-collab-backend-telepathy \
+ --enable-clipart \
+ --enable-statusbar \
+ --enable-templates \
+ --with-gio \
+ --without-gnomevfs \
+ --without-gtk2 \
+ $(use_enable debug) \
+ $(use_with goffice goffice) \
+ $(use_with calendar libical) \
+ $(use_enable cups print) \
+ $(use_enable collab collab-backend-xmpp) \
+ $(use_enable collab collab-backend-tcp) \
+ $(use_enable collab collab-backend-service) \
+ $(use_with eds evolution-data-server) \
+ $(use_enable introspection) \
+ $(use_with map champlain) \
+ $(use_with redland) \
+ $(use_enable spell)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-office/abiword/files/abiword-3.0.4-enchant-2.patch b/app-office/abiword/files/abiword-3.0.4-enchant-2.patch
new file mode 100644
index 000000000000..3ded3600a2b9
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.4-enchant-2.patch
@@ -0,0 +1,54 @@
+From ae05e92df5a5d6151641622c83d35a6fdba47b1f Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Fri, 22 Nov 2019 20:02:52 -0500
+Subject: [PATCH] Require enchant 2 now
+
+---
+ configure.ac | 2 +-
+ src/af/xap/xp/enchant_checker.cpp | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f2e392f04..3e1697ced 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -94,7 +94,7 @@
+ "
+
+ # optional deps
+-enchant_req='enchant >= 1.2.0'
++enchant_req='enchant-2'
+ gio_req='gio-2.0'
+ goffice_req='libgoffice-0.10 >= 0.10.0'
+
+--- a/src/af/xap/xp/enchant_checker.cpp
++++ b/src/af/xap/xp/enchant_checker.cpp
+@@ -127,7 +127,7 @@
+ pvSugg->addItem (ucszSugg);
+ }
+
+- enchant_dict_free_suggestions (m_dict, suggestions);
++ enchant_dict_free_string_list(m_dict, suggestions);
+ }
+
+ return pvSugg;
+@@ -139,7 +139,7 @@
+
+ if (word && len) {
+ UT_UTF8String utf8 (word, len);
+- enchant_dict_add_to_personal (m_dict, utf8.utf8_str(), utf8.byteLength());
++ enchant_dict_add(m_dict, utf8.utf8_str(), utf8.byteLength());
+ return true;
+ }
+ return false;
+@@ -150,7 +150,7 @@
+ UT_return_val_if_fail (m_dict, false);
+
+ UT_UTF8String ignore (toCorrect, toCorrectLen);
+- return enchant_dict_is_in_session (m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
++ return enchant_dict_is_added(m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
+ }
+
+ void EnchantChecker::ignoreWord (const UT_UCSChar *toCorrect, size_t toCorrectLen)
+--
+2.24.1