summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-06-19 08:21:14 +0200
committerHans de Graaff <graaff@gentoo.org>2022-06-19 08:22:41 +0200
commit55fb06f5b9a9890a3f6f4726941d9d33aee3fd8b (patch)
tree24e21e87028f4103e8e2eee8c45acfe565ad281a
parentdev-ruby/railties: drop 5.2.6, 5.2.7.1 (diff)
downloadgentoo-55fb06f5b9a9890a3f6f4726941d9d33aee3fd8b.tar.gz
gentoo-55fb06f5b9a9890a3f6f4726941d9d33aee3fd8b.tar.bz2
gentoo-55fb06f5b9a9890a3f6f4726941d9d33aee3fd8b.zip
dev-ruby/activerecord: drop 5.2.6, 5.2.7.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activerecord/Manifest2
-rw-r--r--dev-ruby/activerecord/activerecord-5.2.6.ebuild89
-rw-r--r--dev-ruby/activerecord/activerecord-5.2.7.1.ebuild93
3 files changed, 0 insertions, 184 deletions
diff --git a/dev-ruby/activerecord/Manifest b/dev-ruby/activerecord/Manifest
index 522c2d97c624..c81cae520f54 100644
--- a/dev-ruby/activerecord/Manifest
+++ b/dev-ruby/activerecord/Manifest
@@ -1,5 +1,3 @@
-DIST rails-5.2.6.tgz 8841270 BLAKE2B 8e813f376446ef249aa3b48934d3cb5ae125c09c54353cc93557c3bee4f23e47ae7ceffab75d5cbfb691daed85149d9054337b468a0010bc5c7ebb879502396b SHA512 465e017591a9962a2e0dec2eac9669d5f507d0904e9eec50fbc8848d804ba5f1eb3220fd5acc949845f048f59cfc5e43f099707650edf301d6595e70e33888c7
-DIST rails-5.2.7.1.tgz 8847972 BLAKE2B 13e5f47431a7611c1fe7ed490198a81634670460effdb14e6657bbc3455388da26db6a611f363b93b35e25a6d2693f227ef2be960d432770afd63906a2ca2b4f SHA512 64b155d522a944eed7ba08417423ebc8b3a6d2ecd39940021c37f54ae3af649d0de6dc1794b4b295d4874eb58cb17bf11d285daa146f37113c42c3aed9cc39c6
DIST rails-5.2.8.tgz 8847449 BLAKE2B 11937ee2aeea39cade43829a01430315a997fef070fc73a1e63baaff8b3631f82561c7acdd44cf1981501424be68d814001dd26cbf7678ca987a8311d109d367 SHA512 98e1b36bdd4235e983d0805b6ff9779e3793d1bed486dc6de854215c4294334d5036157a527c1222cc2be4c107754553dadf2bf86e65ce6561dd8152c47ef84a
DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
DIST rails-6.0.4.8.tgz 18574385 BLAKE2B be6ea79fa452831e1c17ed550f875500c4b00ebf04223335abe8b1e42738f96e6d62ded24913501042a165833235082fde8865cc451dc322a4d7365f9fd6f1b9 SHA512 da48a68029014102e00837a1817d573f293b341716c2ae17fa12f15910a97fcd28ef8b53cb539cc1c029c9916002071485aeddb0e9c6b42aa8d24feeadd5970c
diff --git a/dev-ruby/activerecord/activerecord-5.2.6.ebuild b/dev-ruby/activerecord/activerecord-5.2.6.ebuild
deleted file mode 100644
index 7d9e1a5560d9..000000000000
--- a/dev-ruby/activerecord/activerecord-5.2.6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby25 ruby26"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="https://github.com/rails/rails/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="mysql postgres sqlite"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- dev-ruby/arel:9.0
- sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
- mysql? ( dev-ruby/mysql2:0.5 )
- postgres? ( >=dev-ruby/pg-0.18.0:* )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/actionmailer-${PV}
- >=dev-ruby/sqlite3-1.3.6
- dev-ruby/mocha
- dev-ruby/minitest:5
- )"
-
-DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- rm ../Gemfile.lock || die
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -e '/bcrypt/ s/3.0.0/3.0/' \
- -i ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' \
- ../Gemfile || die
-
- sed -e '3i gem "activesupport", "~> 5.2.0"' \
- -e '3i gem "activerecord", "~> 5.2.0"' \
- -e '3i gem "activemodel", "~> 5.2.0"' \
- -i test/cases/helper.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid single test using mysql dependencies.
- rm test/cases/invalid_connection_test.rb || die
-
- # Avoid failing test that makes bad assumptions on database state.
- sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
- test/cases/associations/has_many_associations_test.rb
-
- # Avoid test failing to bind limit length in favor of security release
- sed -i -e '/test_too_many_binds/askip "Fails on Gentoo"' test/cases/bind_parameter_test.rb || die
-}
-
-each_ruby_test() {
- if use sqlite; then
- MT_NO_PLUGINS=true ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
-}
diff --git a/dev-ruby/activerecord/activerecord-5.2.7.1.ebuild b/dev-ruby/activerecord/activerecord-5.2.7.1.ebuild
deleted file mode 100644
index 42a1a3c55ec4..000000000000
--- a/dev-ruby/activerecord/activerecord-5.2.7.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby25 ruby26"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="https://github.com/rails/rails/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="mysql postgres sqlite"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- dev-ruby/arel:9.0
- sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
- mysql? ( dev-ruby/mysql2:0.5 )
- postgres? ( >=dev-ruby/pg-0.18.0:* )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/actionmailer-${PV}
- >=dev-ruby/sqlite3-1.3.6
- dev-ruby/mocha
- dev-ruby/minitest:5
- )"
-
-DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- rm ../Gemfile.lock || die
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -e '/bcrypt/ s/3.0.0/3.0/' \
- -i ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' \
- ../Gemfile || die
-
- sed -e '3i gem "activesupport", "~> 5.2.0"' \
- -e '3i gem "activerecord", "~> 5.2.0"' \
- -e '3i gem "activemodel", "~> 5.2.0"' \
- -e '3i gem "psych", "~> 3.0"' \
- -i test/cases/helper.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid single test using mysql dependencies.
- rm test/cases/invalid_connection_test.rb || die
-
- # Avoid failing test that makes bad assumptions on database state.
- sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
- test/cases/associations/has_many_associations_test.rb
-
- # Avoid test failing to bind limit length in favor of security release
- sed -i -e '/test_too_many_binds/askip "Fails on Gentoo"' test/cases/bind_parameter_test.rb || die
-
- # Avoid test failures due to sqlite explain changes
- rm -f test/cases/adapters/sqlite3/explain_test.rb || die
-}
-
-each_ruby_test() {
- if use sqlite; then
- MT_NO_PLUGINS=true ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
-}