summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-27 15:24:48 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-27 15:24:48 +0200
commit5606c67fcf08f130f05628fbaf1688566a674e80 (patch)
treea92f0de6eefcb9056475520f8b3ce1e3a2ec7547
parentsys-kernel/bliss-initramfs: adding python 3.6 compat to ebuilds (diff)
downloadgentoo-5606c67f.tar.gz
gentoo-5606c67f.tar.bz2
gentoo-5606c67f.zip
net-analyzer/hydra: Version bump (bug #626184).
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--net-analyzer/hydra/Manifest1
-rw-r--r--net-analyzer/hydra/hydra-8.6.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-analyzer/hydra/Manifest b/net-analyzer/hydra/Manifest
index f65cb39c9ab7..994065c14d01 100644
--- a/net-analyzer/hydra/Manifest
+++ b/net-analyzer/hydra/Manifest
@@ -1,3 +1,4 @@
DIST hydra-8.1.tar.gz 559031 SHA256 e4bc2fd11f97a8d985a38a31785c86d38cc60383e47a8f4a5c436351e5135f19 SHA512 7608dd365865e5976bea446faedaad9f0334e7572fd0ee47a601c471471fc7c8a922c7114f4df08705b34b29144d3a6552e66148adf6b0f92c67301119c94959 WHIRLPOOL b1555fe1a8257c88f8f5c110fce1d06834eb6dadad394b61e2a90c3289b8fdd117944da160871003b1583aefb81a02d5c49a653e8de7d3adcd07917ae760c83c
DIST hydra-8.4.tar.gz 1205609 SHA256 482846580888f54e000bb125e263a65c32fa28ba86c9d4012371cf55c3bdc140 SHA512 62c53f1725eb5b965d16d293cd90ab5e74779eba8fe2e2ab9094f51851fa24acfd74574f509a7914af8254e43197d803cca6b41eace3557d9599d79d695f6a48 WHIRLPOOL aecc31645e7775662e32b766baa942e92e31143e5b6fbe64620ee85179288dc60f3ada477b4605444769c9e76c17d94835db5f3651af409d5562a2e8971279ef
DIST hydra-8.5.tar.gz 1193694 SHA256 69b69d16ce9499f3a941836b4d8a1c8a3ff9b905c921cc8c588a3af7f65a3b4b SHA512 67fd92bd5983a94314334471c526b71ca77dec6e359e55f4fb2fc78160e2065957b6c9af1ff694bcc5334893a8b5e0fe1b39d984248bde4e55dc2a9f9a8b1271 WHIRLPOOL a71e1cb94986ead4eb114f19738cc1e3ed7288220a79d67ef4e6d93bc5c59910ecee1207fd7a10da9300cba9c3b92d5c6f4cdc3bb1a30bde8db523d7d4cce998
+DIST hydra-8.6.tar.gz 1200238 SHA256 05a87eb018507b24afca970081f067e64441460319fb75ca1e64c4a1f322b80b SHA512 d5d70b5df54fbc556c6db9e9e44b869f29e54aca03dc3cc9e1777d310fcf604b9602ba08250c5bb0d009963dc0ca5c169e61d3f64d7ec2383760fc819d6b6c61 WHIRLPOOL 898f605d556dcb6efe4f4c4b3114c4a2c53dd6baef4956cbf413ef98074ce30b4153f05ff4f69103407fd1a753b2530074293f03d13e83e93c88891821b06ee2
diff --git a/net-analyzer/hydra/hydra-8.6.ebuild b/net-analyzer/hydra/hydra-8.6.ebuild
new file mode 100644
index 000000000000..bed5fc36e987
--- /dev/null
+++ b/net-analyzer/hydra/hydra-8.6.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="https://www.thc.org/thc-hydra/"
+SRC_URI="
+ https://github.com/vanhauser-thc/thc-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="firebird gtk idn libressl mysql ncp oracle pcre postgres ssl subversion"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/ncurses:=
+ firebird? ( dev-db/firebird )
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+ idn? ( net-dns/libidn )
+ mysql? ( virtual/mysql )
+ ncp? ( net-fs/ncpfs )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql:* )
+ ssl? ( >=net-libs/libssh-0.4.0 )
+ subversion? ( dev-vcs/subversion )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.4-configure.patch
+)
+S=${WORKDIR}/thc-${P}
+
+src_prepare() {
+ default
+
+ # None of the settings in Makefile.unix are useful to us
+ : > Makefile.unix
+
+ sed -i \
+ -e 's:|| echo.*$::' \
+ -e '/\t-$(CC)/s:-::' \
+ -e '/^OPTS/{s|=|+=|;s| -O3||}' \
+ -e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
+ Makefile.am || die
+}
+
+src_configure() {
+ export OPTS="${CFLAGS}"
+
+ if ! use subversion; then
+ sed -i 's/-lsvn_client-1 -lapr-1 -laprutil-1 -lsvn_subr-1//;s/-DLIBSVN//' configure || die
+ fi
+
+ if ! use mysql; then
+ sed -i 's/-lmysqlclient//;s/-DLIBMYSQLCLIENT//' configure || die
+ fi
+
+ # Linking against libtinfo might be enough here but pkg-config --libs tinfo
+ # would require a USE=tinfo flag and recent linkers should drop libcurses
+ # as needed
+ sed -i \
+ -e 's|-lcurses|'"$( $(tc-getPKG_CONFIG) --libs ncurses)"'|g' \
+ configure || die
+
+ # Note: despite the naming convention, the top level script is not an
+ # autoconf-based script.
+ export NCP_PATH=$(usex ncp /usr/$(get_libdir) '')
+ export NCP_IPATH=$(usex ncp /usr/include '')
+ sh configure \
+ --prefix=/usr \
+ --nostrip \
+ $(use gtk && echo --disable-xhydra) \
+ || die
+
+ if use gtk ; then
+ cd hydra-gtk && \
+ econf
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake XLIBPATHS=''
+ use gtk && emake -C hydra-gtk
+}
+
+src_install() {
+ dobin hydra pw-inspector
+ use gtk && dobin hydra-gtk/src/xhydra
+ dodoc CHANGES README
+}