summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-25 07:48:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-25 08:06:23 +0100
commit5611d4210213bb22e1220e109015207061a21063 (patch)
treeb179757198777579ed0dcb8823551fe486930845
parentdev-python/recurring-ical-events: Bump to 2.1.2 (diff)
downloadgentoo-5611d4210213bb22e1220e109015207061a21063.tar.gz
gentoo-5611d4210213bb22e1220e109015207061a21063.tar.bz2
gentoo-5611d4210213bb22e1220e109015207061a21063.zip
dev-python/pypdf: Bump to 3.17.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/pypdf-3.17.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 46ff1aa4af8b..b4b866a7cd20 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,5 @@
DIST pypdf-3.17.1.gh.tar.gz 7975263 BLAKE2B 27b413dd5f127e22cc0116baeee62115f4b02b2ff39f27b8a7884af2389423c332114cfa826a090683c2ab6583b1a549ee1de775869eaaa0a09237aa52a65ebd SHA512 c23294a67bee6ef4e673c02b045c9ec2d3471f93bfc8530959a02289f94b0aa47e79b24bddd0603731c39ddc5197fc6fc10e668bbd1077a32ecdfc1d33740397
DIST pypdf-3.17.2.gh.tar.gz 7977562 BLAKE2B d33413b1efe38bc147156e199851a2afb712960a377c675ec2197a720d00ef18d143a1176312c8b9b7681839024fb26544b6c09a482e3e24c9041c3d2d191cd1 SHA512 430bae4aeb1ffb8c75fd95daf04622d082725cdcf01637e2e42234bbc867360d9c5e6ebd3782608c1299f9fa1ec7598c49b0195750f58d0d16c3d744895606d8
DIST pypdf-3.17.3.gh.tar.gz 7977650 BLAKE2B eee1e5d86fcd32faa0919f2e9bb8c1cd2630d75f6030f9db05a2b71993038452fbed05bbb5dc63d3562038da19c784170e24682054ad669a35b8027f47cc2d45 SHA512 fe91b4f1d6ad9394e41bcdaa99adb5a6fe15df70a1db0858f560f63352aa279446ad802738306d5d7bd58c699069872a777997621b62429137da5c53b4595ca6
+DIST pypdf-3.17.4.gh.tar.gz 7976829 BLAKE2B c2b7aef937186aecf525729f336ad6d00a8bf40850be17cb450daba5d0100acc0b0c3f51ef242e3cf7ef710d5c40c9f334db94a372b6d6eb4f2270dc00dde156 SHA512 f687a2032f085dac9b920f881f2df9f96e4da2a8dcdd5f971d3601ab05ae4f9b5528d0155adcb5ef01c6d8ffdc4f3d79077706915851bad7868bf761d28c513a
DIST pypdf-sample-files-964fb47b0fbfa89864680582640ae4eedf143890.gh.tar.gz 11668924 BLAKE2B 0c7d8e7cfb2f9d06d7633d57b691ba473d33cfcb58d2f1f83661cef9d755340d05db8767771a385d0ba88aa904f84b8bc7eafdb5d4f614b7a21a2d138572316f SHA512 28070b575273b6fee3173e797ed5bac618f8e8aca16d0122dcf3b4b16cedbcad69b84a9bc4be65037695597bcc1fa7898cdf766c37915c49f880a0c6ca057e68
diff --git a/dev-python/pypdf/pypdf-3.17.4.ebuild b/dev-python/pypdf/pypdf-3.17.4.ebuild
new file mode 100644
index 000000000000..c3de6265ee0d
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.17.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+ tests/test_writer.py::test_merging_many_temporary_files
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}