summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-11-12 20:49:56 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-12 20:53:14 +0100
commit561d2d1e6292412a50dbcd379cfcfda76ed7611b (patch)
tree26a293efa52754e00332bce3276b2341bf264181
parentapp-emulation/qemu: 7.1.0 revbump, fixing 3 qemu-user bugs (diff)
downloadgentoo-561d2d1e6292412a50dbcd379cfcfda76ed7611b.tar.gz
gentoo-561d2d1e6292412a50dbcd379cfcfda76ed7611b.tar.bz2
gentoo-561d2d1e6292412a50dbcd379cfcfda76ed7611b.zip
sys-cluster/rdma-core: sync live
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index 0fa2ec46e46b..07c5665528d4 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake python-single-r1 udev systemd
+inherit cmake perl-functions python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -60,10 +60,12 @@ BDEPEND="
PATCHES=( "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch )
src_configure() {
+ perl_set_version
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
-DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
+ -DCMAKE_INSTALL_PERLDIR="${VENDOR_LIB}"
-DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
-DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
@@ -80,8 +82,7 @@ src_configure() {
src_install() {
cmake_src_install
- udev_dorules "${ED}"/etc/udev/rules.d/70-persistent-ipoib.rules
- rm -r "${ED}"/etc/{udev,init.d} || die
+ udev_dorules "${ED}"/usr/share/doc/${PF}/70-persistent-ipoib.rules
if use neigh; then
newinitd "${FILESDIR}"/ibacm.init ibacm