summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2023-04-09 08:40:32 -0500
committerErik Mackdanz <stasibear@gentoo.org>2023-04-09 08:40:38 -0500
commit5620e457eaacffb8586a1e09249aab6763a5ba44 (patch)
tree8d4e7e7791a6b226e6148248580fb45c3d6e0f05
parentdev-perl/Web-Machine: new package, add 0.17 (diff)
downloadgentoo-5620e457eaacffb8586a1e09249aab6763a5ba44.tar.gz
gentoo-5620e457eaacffb8586a1e09249aab6763a5ba44.tar.bz2
gentoo-5620e457eaacffb8586a1e09249aab6763a5ba44.zip
dev-perl/Path-Dispatcher: new package, add 1.08
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
-rw-r--r--dev-perl/Path-Dispatcher/Manifest1
-rw-r--r--dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild26
-rw-r--r--dev-perl/Path-Dispatcher/metadata.xml31
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/Path-Dispatcher/Manifest b/dev-perl/Path-Dispatcher/Manifest
new file mode 100644
index 000000000000..b505a5fab35a
--- /dev/null
+++ b/dev-perl/Path-Dispatcher/Manifest
@@ -0,0 +1 @@
+DIST Path-Dispatcher-1.08.tar.gz 50388 BLAKE2B cea31a6e2f846f60dd28682e50c50cc7cc5dc1ee957329073a952d1ed17d28deb967de50a438d2c53432949010a8e2f39b953d0f836339e19a310afc097e4330 SHA512 3cda047a70dafc0ce54dad949b567d872b9c911c670a66d5f022cf21706ced2b6ff40b615458c2b7b06693141f9504beceb93c7c6b532eba53f32290b93b27c2
diff --git a/dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild b/dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild
new file mode 100644
index 000000000000..814ac1ab7c78
--- /dev/null
+++ b/dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Flexible and extensible dispatch"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Moo
+ dev-perl/MooX-TypeTiny
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/Type-Tiny
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build-Tiny
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/dev-perl/Path-Dispatcher/metadata.xml b/dev-perl/Path-Dispatcher/metadata.xml
new file mode 100644
index 000000000000..b575f67909f3
--- /dev/null
+++ b/dev-perl/Path-Dispatcher/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Path-Dispatcher</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Dispatch</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Match</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Path</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Role::Rules</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Alternation</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Always</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Chain</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::CodeRef</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Dispatch</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Empty</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Enum</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Eq</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Intersection</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Metadata</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Regex</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Sequence</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Tokens</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Under</remote-id>
+ </upstream>
+</pkgmetadata>