summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-08-27 16:20:34 -0500
committerMatthew Thode <mthode@mthode.org>2015-08-27 16:22:01 -0500
commit56240c05e5e9fcbeabef53b465f01dadda09b4bb (patch)
tree200bdf9eccfefcdc558ca0af4cf2bf14f850fdf1
parentdev-lisp/sbcl: bump to version 1.2.14 (diff)
downloadgentoo-56240c05.tar.gz
gentoo-56240c05.tar.bz2
gentoo-56240c05.zip
herd/openstack: Split out libs from dev-python/PyECLib
gentoo-bug: 558884 gentoo-bug: 558886
-rw-r--r--dev-libs/gf-complete/Manifest1
-rw-r--r--dev-libs/gf-complete/gf-complete-0.0.0.ebuild30
-rw-r--r--dev-libs/gf-complete/metadata.xml9
-rw-r--r--dev-libs/jerasure/Manifest1
-rw-r--r--dev-libs/jerasure/jerasure-0.0.0.ebuild30
-rw-r--r--dev-libs/jerasure/metadata.xml9
-rw-r--r--dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild33
-rw-r--r--dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild27
-rw-r--r--dev-python/PyECLib/files/PyECLib-usr-local2.patch51
9 files changed, 158 insertions, 33 deletions
diff --git a/dev-libs/gf-complete/Manifest b/dev-libs/gf-complete/Manifest
new file mode 100644
index 000000000000..86ef162f21ed
--- /dev/null
+++ b/dev-libs/gf-complete/Manifest
@@ -0,0 +1 @@
+DIST gf-complete-0.0.0.tar.gz 596339 SHA256 7ec49204d0ce28f9158c65535183f55c0964fad02707234f4982917308ca521b SHA512 7942a29b80972fffab15dc86c560345911db5aa976d2c505804d0eff10c9135f674f3511b579e2bac26342ca53a81d323826a1ff1d790836a4650a07769851a2 WHIRLPOOL 5e8b27c3514300869c42f6af4084dc498b7ad8bc02a2a2b5120038d3598b364f2344f323ca2b2d55c231f1d2d842266305585bab20582fd1bbc752e27323338a
diff --git a/dev-libs/gf-complete/gf-complete-0.0.0.ebuild b/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
new file mode 100644
index 000000000000..f19f324f69a0
--- /dev/null
+++ b/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A Comprehensive Open Source Library for Galois Field Arithmetic"
+HOMEPAGE="http://jerasure.org/"
+SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/${P}.tar.gz"
+S="${WORKDIR}/${PN}.git"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/ -O3 $(SIMD_FLAGS)//g' src/Makefile.am tools/Makefile.am test/Makefile.am examples/Makefile.am|| die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/gf-complete/metadata.xml b/dev-libs/gf-complete/metadata.xml
new file mode 100644
index 000000000000..4d820980847a
--- /dev/null
+++ b/dev-libs/gf-complete/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/jerasure/Manifest b/dev-libs/jerasure/Manifest
new file mode 100644
index 000000000000..54df35adbd05
--- /dev/null
+++ b/dev-libs/jerasure/Manifest
@@ -0,0 +1 @@
+DIST jerasure-0.0.0.tar.gz 506400 SHA256 4bb55ed9858cc623849507ca22f854e52d7408251733e46c6f58bea12cd41d14 SHA512 447fc9b4b2e2bb30baa241bc8f509eba71d34b8fc504f2fd6bbc6adb8b6f32d171f4d486dc08afd6f594064e11252a246dd663a1d6beda5b3129c4d9cdaf98db WHIRLPOOL 968f3059ac37fd2a168b067c84f311015f0c37c0b0517d496bd940d3352b5027e4e02c99b6bc918eea9d2dc4d5bf308f3bd6625e19710a0cd03cf6297501b6d5
diff --git a/dev-libs/jerasure/jerasure-0.0.0.ebuild b/dev-libs/jerasure/jerasure-0.0.0.ebuild
new file mode 100644
index 000000000000..458a416eef93
--- /dev/null
+++ b/dev-libs/jerasure/jerasure-0.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A Library in C Facilitating Erasure Coding for Storage Applications"
+HOMEPAGE="http://jerasure.org/"
+SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/${P}.tar.gz"
+S="${WORKDIR}/${PN}.git"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/gf-complete"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/ $(SIMD_FLAGS)//g' src/Makefile.am Examples/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/jerasure/metadata.xml b/dev-libs/jerasure/metadata.xml
new file mode 100644
index 000000000000..4d820980847a
--- /dev/null
+++ b/dev-libs/jerasure/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild b/dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild
deleted file mode 100644
index 46a3b946ae75..000000000000
--- a/dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Messaging API for RPC and notifications over a number of different messaging transports"
-HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-libs/liberasurecode"
-
-PATCHES=(
- "${FILESDIR}/1.0.7-erasurecode_locations.patch"
- "${FILESDIR}/PyECLib-usr-local.patch"
-)
-
-python_install() {
- distutils-r1_python_install
- # sed -i "s/^libdir.*$/libdir='\/usr\/lib'/g" "${D}"/usr/lib/libgf_complete.la || die
- # sed -i "s/^dependency_libs.*$/dependency_libs=''/g" "${D}"/usr/lib/libgf_complete.la "${D}"/usr/lib/libJerasure.la || die
- # package installs broken la files...
- rm "${D}"/usr/lib/*.la || die
-}
diff --git a/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild b/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..12215bf8e618
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over a number of different messaging transports"
+HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/PyECLib-usr-local2.patch"
+)
diff --git a/dev-python/PyECLib/files/PyECLib-usr-local2.patch b/dev-python/PyECLib/files/PyECLib-usr-local2.patch
new file mode 100644
index 000000000000..c0b23d477416
--- /dev/null
+++ b/dev-python/PyECLib/files/PyECLib-usr-local2.patch
@@ -0,0 +1,51 @@
+--- setup.py 2015-08-27 14:33:44.643517647 -0500
++++ setup.py.new 2015-08-27 14:34:05.202517349 -0500
+@@ -60,13 +60,12 @@
+
+ default_library_paths = [default_python_libdir,
+ ('%s/usr/local/lib' % _exec_prefix),
+- '/lib', '/usr/lib', '/usr/local/lib',
+- 'src/c/liberasurecode-1.0.7/src/.libs']
++ '/lib', '/usr/lib', '/usr/local/lib']
+
+ default_include_paths = [default_python_incdir,
+ '/usr/local/include', '/usr/local/include/jerasure',
+ '/usr/include', 'src/c/pyeclib_c',
+- '/usr/local/include']
++ '/usr/include/liberasurecode', '/usr/local/include']
+
+ libflags = ''
+ includeflags = ''
+@@ -120,6 +119,7 @@
+ if (os.path.isfile(library_file_path)):
+ missing = False
+ break
++ missing = False
+ if missing:
+ # try using an integrated copy of the library
+ srcpath = "src/c/"
+@@ -228,24 +228,6 @@
+ ldpath_str = "DYLD_LIBRARY_PATH"
+ else:
+ ldpath_str = "LD_LIBRARY_PATH"
+- print("***************************************************")
+- print("** ")
+- print("** PyECLib libraries have been installed to: ")
+- print("** %susr/local/lib" % installroot)
+- print("** ")
+- print("** Any user using this library must update: ")
+- print("** %s" % ldpath_str)
+- print("** ")
+- print("** Run 'ldconfig' or place this line: ")
+- print("** export %s=%s" % (ldpath_str, "%susr/local/lib"
+- % installroot))
+- print("** ")
+- print("** into .bashrc, .profile, or the appropriate shell")
+- print("** start-up script! Also look at ldconfig(8) man ")
+- print("** page for a more static LD configuration ")
+- print("** ")
+- print("***************************************************")
+-
+
+ module = Extension('pyeclib_c',
+ define_macros=[('MAJOR VERSION', '0'),