summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 09:32:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 10:26:42 +0100
commit56242a2eda1d86a1b813c206bf83e919674b9253 (patch)
tree1a281954d28e233e9b7ea3c59ecd53a23a8f8388
parentkde-plasma/plasma-systemmonitor: drop 5.25.5 (diff)
downloadgentoo-56242a2e.tar.gz
gentoo-56242a2e.tar.bz2
gentoo-56242a2e.zip
kde-plasma/plasma-thunderbolt: drop 5.25.5-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest1
-rw-r--r--kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch71
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild40
3 files changed, 0 insertions, 112 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index 796d94698ac6..901746ff23c4 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1,3 +1,2 @@
-DIST plasma-thunderbolt-5.25.5.tar.xz 68828 BLAKE2B 2e43e20f1413b2edf502f5d7a7b766d956e5bae7f69b983f234546270c629148baf126415915360d8991292139c2d41c687df308d143e359c5a47343d35ddc29 SHA512 73280e422e30893f90586ff7248a6ec0db8d8b518a205187c550545381ee34b09fa648ce819129f8cf2823877f7fcdbbc8e3484a4ca86fa427b2c95915f532b7
DIST plasma-thunderbolt-5.26.5.tar.xz 71912 BLAKE2B 40546213181a5b426aaf3bbd03f1a32a3a7cff70438acd1130a2cba364375b3803fb7eeb0da8c0e8489d5cd49881ace39b3ce10eae01cb18fa51ef612f74d2c4 SHA512 182fa9df929eeca0c3fc3960f731c120e4a09fbc4b42babcc1d99374440b8bf32c564628c58fa5492b5ec9d8d50f98160c845d48e3215846e5ca7385256a783b
DIST plasma-thunderbolt-5.26.90.tar.xz 71808 BLAKE2B 8b1d8ac1bec8ded89a0752850a42d09381f3a07efbefbbd8bbe98a73190b3fe3a9038d13574a6d91e76b791b5c885f69c0d433b964a64cb65be99f00acce50db SHA512 80416ce459f590ec2de1da1d8236b3e3bb5ea6703caa5ff99dd60fe938e2e8765c23678fec0e8a86ce05e9b8c92736acf9a009d8f59ce3ef675db0aaec346977
diff --git a/kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch b/kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch
deleted file mode 100644
index f45edfa86f77..000000000000
--- a/kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 09c37c1c312991d08c10c7af94a83902150cb3ad Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Mon, 27 Jun 2022 16:46:08 +0100
-Subject: [PATCH] Avoid combining smart pointers and qobject parent ownership
-
-Devices are stored as QSharedPointer<Device> mDevices. If something has
-the memory managed explicitly we don't want QObject parents to also try
-and do the same job.
-
-BUG: 439192
----
- src/lib/device.cpp | 4 ++--
- src/lib/device.h | 2 +-
- src/lib/manager.cpp | 4 ++--
- 3 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/lib/device.cpp b/src/lib/device.cpp
-index b79d029..94964be 100644
---- a/src/lib/device.cpp
-+++ b/src/lib/device.cpp
-@@ -45,10 +45,10 @@ Device::Device(const QDBusObjectPath &path, QObject *parent)
-
- Device::~Device() = default;
-
--QSharedPointer<Device> Device::create(const QDBusObjectPath &path, QObject *parent)
-+QSharedPointer<Device> Device::create(const QDBusObjectPath &path)
- {
- try {
-- return QSharedPointer<Device>::create(path, parent);
-+ return QSharedPointer<Device>::create(path);
- } catch (const DBusException &e) {
- qCWarning(log_libkbolt, "%s", e.what());
- return {};
-diff --git a/src/lib/device.h b/src/lib/device.h
-index 9b7e0f0..d183b12 100644
---- a/src/lib/device.h
-+++ b/src/lib/device.h
-@@ -46,7 +46,7 @@ class KBOLT_EXPORT Device : public QObject, public QEnableSharedFromThis<Device>
- friend class Manager;
-
- public:
-- static QSharedPointer<Device> create(const QDBusObjectPath &path, QObject *parent = nullptr);
-+ static QSharedPointer<Device> create(const QDBusObjectPath &path);
- explicit Device(QObject *parent = nullptr);
- ~Device() override;
-
-diff --git a/src/lib/manager.cpp b/src/lib/manager.cpp
-index 683c28c..99f1732 100644
---- a/src/lib/manager.cpp
-+++ b/src/lib/manager.cpp
-@@ -26,7 +26,7 @@ Manager::Manager(QObject *parent)
- }
-
- connect(mInterface.get(), &ManagerInterface::DeviceAdded, this, [this](const QDBusObjectPath &path) {
-- if (auto device = Device::create(path, this)) {
-+ if (auto device = Device::create(path)) {
- mDevices.push_back(device);
- qCDebug(log_libkbolt,
- "New Thunderbolt device %s (%s) added, status=%s",
-@@ -46,7 +46,7 @@ Manager::Manager(QObject *parent)
-
- const auto devicePaths = mInterface->ListDevices().argumentAt<0>();
- for (const auto &devicePath : devicePaths) {
-- if (auto device = Device::create(devicePath, this)) {
-+ if (auto device = Device::create(devicePath)) {
- qCDebug(log_libkbolt,
- "Discovered Thunderbolt device %s (%s), status=%s",
- qUtf8Printable(device->uid()),
---
-GitLab
-
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild
deleted file mode 100644
index b68b25270cb1..000000000000
--- a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="true"
-KFMIN=5.95.0
-PVCUT=$(ver_cut 1-3)
-QTMIN=5.15.5
-inherit ecm plasma.kde.org
-
-DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
-HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
-
-LICENSE="|| ( GPL-2 GPL-3+ )"
-SLOT="5"
-KEYWORDS="amd64 ~riscv x86"
-IUSE=""
-
-# tests require DBus
-RESTRICT="test"
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
-"
-RDEPEND="${DEPEND}
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=kde-frameworks/kirigami-${KFMIN}:5
- sys-apps/bolt
-"
-
-PATCHES=( "${FILESDIR}/${P}-kcm-crash.patch" )