summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-22 07:19:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-22 07:54:22 +0200
commit5635b8ffa2e41cb2aff0535ce7a3d49ec3859e70 (patch)
tree990542f255aad95dae103b8a4401a65c83d03fe2
parentdev-python/sure: Bump to 2.0.0 (diff)
downloadgentoo-5635b8ffa2e41cb2aff0535ce7a3d49ec3859e70.tar.gz
gentoo-5635b8ffa2e41cb2aff0535ce7a3d49ec3859e70.tar.bz2
gentoo-5635b8ffa2e41cb2aff0535ce7a3d49ec3859e70.zip
dev-python/google-auth: Bump to 1.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.32.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index e41093ef1674..a7c16e8f2b83 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -2,3 +2,4 @@ DIST google-auth-1.30.0.tar.gz 169598 BLAKE2B 4b0a0e66255abc11c697ca2c3d77ea0b7c
DIST google-auth-1.30.1.tar.gz 169244 BLAKE2B e496239807ab9ca64e1b5dc39726fa22b56d55f14883c983673064b8ea33f80dee013654d4808fead0d06e8b6ddc53554d094f42aede6e06224dc3a3c04e88d1 SHA512 7e35f5be9be160ddef4b579c2e5bc966f1d64f8f0bb75220e22fd3edb9c6f6140bdcf68055fdb13dd370e3d543206900cc9403237eb328d69418a384a4d0fe26
DIST google-auth-1.30.2.tar.gz 169368 BLAKE2B c01191313b4bd7ffdc62fbca20aeadcb01fcb1f26e4c11504f88c2582b9a3dca10046edd5d2fe88c98980fb09e4d68da99bf0b8b5692abcf5271994515f91765 SHA512 f133ef403f8a3c92437055f2fd0e5f607199a0bfd9a76a44075a9be8ec16c4d4822d58d85fa52ade4c448e11cb6822f7e8da03ab72f3dddfb811c8d7a846f841
DIST google-auth-1.31.0.tar.gz 170970 BLAKE2B ee6c9e72657d0902e53c0c56ef5eb802815979f272e9ee8e038dbb05af64eabcf3d6b005f2eedaa0d2b2c4da815bdbd89e1246fc37f9b7e7760252a040ae2a27 SHA512 c594ef070983a1b0d5dccbc42ecd8020866911463b672d52b6f32b22dbcd4fccdc038d1a56f6af556553f086b161f37eba93dee3bfb8726329249c3d73efdd9f
+DIST google-auth-1.32.0.tar.gz 171423 BLAKE2B 8888a9193b356f2d0d846a36c436cfc1cc60a973a162983c583bb1d5eacb183381424bebbaad7c4c7a9b777c8d5a3b61c490ad0cece4b9d6e0bd1e03fb71f49f SHA512 0f11de110828eca0514b032e422d72ab3979c99ed20bba3d79583cc33707a6cbfcb69b50f27f1702e803620c852eb6fe4bfc431d2e9db6774d26ca6f783042ba
diff --git a/dev-python/google-auth/google-auth-1.32.0.ebuild b/dev-python/google-auth/google-auth-1.32.0.ebuild
new file mode 100644
index 000000000000..02c43c1586f4
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.32.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}