summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-28 01:40:42 +0000
committerSam James <sam@gentoo.org>2021-05-28 01:40:56 +0000
commit5636983cd1c5a681e22e28b3a115c168f80f693d (patch)
tree28b73a8dfda0690670c739cdea18175f45fe42b9
parentdev-util/colm: drop Julia check which causes sandbox failure (diff)
downloadgentoo-5636983cd1c5a681e22e28b3a115c168f80f693d.tar.gz
gentoo-5636983cd1c5a681e22e28b3a115c168f80f693d.tar.bz2
gentoo-5636983cd1c5a681e22e28b3a115c168f80f693d.zip
media-libs/alsa-lib: fix musl build
Closes: https://bugs.gentoo.org/792570 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.2.4.ebuild3
-rw-r--r--media-libs/alsa-lib/files/alsa-lib-1.2.4-musl.patch32
2 files changed, 34 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.4.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.4.ebuild
index 51bdbff6f135..e7a0a5539cbc 100644
--- a/media-libs/alsa-lib/alsa-lib-1.2.4.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.2.4.ebuild
@@ -25,7 +25,8 @@ RDEPEND="python? ( ${PYTHON_DEPS} )
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}/${PN}-1.1.6-missing_files.patch" #652422
+ "${FILESDIR}/${PN}-1.1.6-missing_files.patch" # bug #652422
+ "${FILESDIR}/${PN}-1.2.4-musl.patch" # bug #792570
)
pkg_setup() {
diff --git a/media-libs/alsa-lib/files/alsa-lib-1.2.4-musl.patch b/media-libs/alsa-lib/files/alsa-lib-1.2.4-musl.patch
new file mode 100644
index 000000000000..54e6c0e0d23e
--- /dev/null
+++ b/media-libs/alsa-lib/files/alsa-lib-1.2.4-musl.patch
@@ -0,0 +1,32 @@
+https://github.com/alsa-project/alsa-lib/commit/ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e
+https://bugs.gentoo.org/792570
+
+From ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e Mon Sep 17 00:00:00 2001
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Thu, 22 Oct 2020 20:57:32 +0200
+Subject: [PATCH] dlmisc: the snd_plugin_dir_set / snd_plugin_dir must be
+ declared even for \!DL_ORIGIN_AVAILABLE
+
+Fixes: 8580c081c2 ("dlsym: add support for ALSA_PLUGIN_DIR environment variable")
+BugLink: https://github.com/alsa-project/alsa-lib/issues/91
+Signed-off-by: Jaroslav Kysela <perex@perex.cz>
+---
+ src/dlmisc.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/dlmisc.c b/src/dlmisc.c
+index c9517c55..f20eb593 100644
+--- a/src/dlmisc.c
++++ b/src/dlmisc.c
+@@ -42,11 +42,9 @@
+ #ifndef PIC
+ struct snd_dlsym_link *snd_dlsym_start = NULL;
+ #endif
+-#ifdef DL_ORIGIN_AVAILABLE
+ static int snd_plugin_dir_set = 0;
+ static char *snd_plugin_dir = NULL;
+ #endif
+-#endif
+
+ #if defined(DL_ORIGIN_AVAILABLE) && defined(HAVE_LIBPTHREAD)
+ static pthread_mutex_t snd_dlpath_mutex = PTHREAD_MUTEX_INITIALIZER;