summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-16 01:06:26 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-16 01:13:43 +0100
commit564e540c8be63a473ca855fd48fd23e68f82e72f (patch)
treeda4ceb56a6686c0edbb1393579751fdf018db0e8
parentmedia-libs/vigra: Make sure TeX font generation stays in the sandbox, bug 555078 (diff)
downloadgentoo-564e540c8be63a473ca855fd48fd23e68f82e72f.tar.gz
gentoo-564e540c8be63a473ca855fd48fd23e68f82e72f.tar.bz2
gentoo-564e540c8be63a473ca855fd48fd23e68f82e72f.zip
net-print/cups: Tone down USB_PRINTER warning, bug 501122
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-print/cups/cups-2.2.2-r1.ebuild15
-rw-r--r--net-print/cups/cups-2.2.2-r2.ebuild15
-rw-r--r--net-print/cups/cups-9999.ebuild15
3 files changed, 15 insertions, 30 deletions
diff --git a/net-print/cups/cups-2.2.2-r1.ebuild b/net-print/cups/cups-2.2.2-r1.ebuild
index a4fe11d96b27..59fd100b94c0 100644
--- a/net-print/cups/cups-2.2.2-r1.ebuild
+++ b/net-print/cups/cups-2.2.2-r1.ebuild
@@ -114,18 +114,13 @@ pkg_setup() {
ewarn "Can't check the linux kernel configuration."
ewarn "You might have some incompatible options enabled."
else
- # recheck that we don't have usblp to collide with libusb
+ # recheck that we don't have usblp to collide with libusb; this should now work in most cases (bug 501122)
if use usb; then
if linux_chkconfig_present USB_PRINTER; then
- eerror "Your usb printers will be managed via libusb. In this case, "
- eerror "${P} requires the USB_PRINTER support disabled."
- eerror "Please disable it:"
- eerror " CONFIG_USB_PRINTER=n"
- eerror "in /usr/src/linux/.config or"
- eerror " Device Drivers --->"
- eerror " USB support --->"
- eerror " [ ] USB Printer support"
- eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
+ elog "Your USB printers will be managed via libusb. In case you run into problems, "
+ elog "please try disabling USB_PRINTER support in your kernel or blacklisting the"
+ elog "usblp kernel module."
+ elog "Alternatively, just disable the usb useflag for cups (your printer will still work)."
fi
else
#here we should warn user that he should enable it so he can print
diff --git a/net-print/cups/cups-2.2.2-r2.ebuild b/net-print/cups/cups-2.2.2-r2.ebuild
index 765945a438d6..24b53a61b147 100644
--- a/net-print/cups/cups-2.2.2-r2.ebuild
+++ b/net-print/cups/cups-2.2.2-r2.ebuild
@@ -113,18 +113,13 @@ pkg_setup() {
ewarn "Can't check the linux kernel configuration."
ewarn "You might have some incompatible options enabled."
else
- # recheck that we don't have usblp to collide with libusb
+ # recheck that we don't have usblp to collide with libusb; this should now work in most cases (bug 501122)
if use usb; then
if linux_chkconfig_present USB_PRINTER; then
- eerror "Your usb printers will be managed via libusb. In this case, "
- eerror "${P} requires the USB_PRINTER support disabled."
- eerror "Please disable it:"
- eerror " CONFIG_USB_PRINTER=n"
- eerror "in /usr/src/linux/.config or"
- eerror " Device Drivers --->"
- eerror " USB support --->"
- eerror " [ ] USB Printer support"
- eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
+ elog "Your USB printers will be managed via libusb. In case you run into problems, "
+ elog "please try disabling USB_PRINTER support in your kernel or blacklisting the"
+ elog "usblp kernel module."
+ elog "Alternatively, just disable the usb useflag for cups (your printer will still work)."
fi
else
#here we should warn user that he should enable it so he can print
diff --git a/net-print/cups/cups-9999.ebuild b/net-print/cups/cups-9999.ebuild
index 765945a438d6..24b53a61b147 100644
--- a/net-print/cups/cups-9999.ebuild
+++ b/net-print/cups/cups-9999.ebuild
@@ -113,18 +113,13 @@ pkg_setup() {
ewarn "Can't check the linux kernel configuration."
ewarn "You might have some incompatible options enabled."
else
- # recheck that we don't have usblp to collide with libusb
+ # recheck that we don't have usblp to collide with libusb; this should now work in most cases (bug 501122)
if use usb; then
if linux_chkconfig_present USB_PRINTER; then
- eerror "Your usb printers will be managed via libusb. In this case, "
- eerror "${P} requires the USB_PRINTER support disabled."
- eerror "Please disable it:"
- eerror " CONFIG_USB_PRINTER=n"
- eerror "in /usr/src/linux/.config or"
- eerror " Device Drivers --->"
- eerror " USB support --->"
- eerror " [ ] USB Printer support"
- eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
+ elog "Your USB printers will be managed via libusb. In case you run into problems, "
+ elog "please try disabling USB_PRINTER support in your kernel or blacklisting the"
+ elog "usblp kernel module."
+ elog "Alternatively, just disable the usb useflag for cups (your printer will still work)."
fi
else
#here we should warn user that he should enable it so he can print