summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-04 17:17:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-04 17:17:39 +0200
commit565193ae54cfbf09e592ed5607b3775986d93c53 (patch)
tree81bf41352f78a77cc0915a2a65aeae5349ee1b2e
parentdev-ruby/rails: add rails 5.1.3 (diff)
downloadgentoo-565193ae.tar.gz
gentoo-565193ae.tar.bz2
gentoo-565193ae.zip
sys-devel/autoconf: Revbump to add another perl-5.26 fix (bug #625576).
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--sys-devel/autoconf/autoconf-2.69-r4.ebuild (renamed from sys-devel/autoconf/autoconf-2.69-r3.ebuild)6
-rw-r--r--sys-devel/autoconf/files/autoconf-2.69-perl-5.26-2.patch30
2 files changed, 34 insertions, 2 deletions
diff --git a/sys-devel/autoconf/autoconf-2.69-r3.ebuild b/sys-devel/autoconf/autoconf-2.69-r4.ebuild
index 54b5079415c2..eac252939367 100644
--- a/sys-devel/autoconf/autoconf-2.69-r3.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69-r4.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
http://git.savannah.gnu.org/r/${PN}.git"
# We need all the tags in order to figure out the right version.
# The git-r3 eclass doesn't support that, so have to stick to 2.
- inherit git-2
+ inherit git-r3
else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
@@ -39,6 +39,8 @@ src_prepare() {
PATCHES+=(
"${FILESDIR}"/${PN}-2.69-perl-5.26.patch
"${FILESDIR}"/${P}-fix-libtool-test.patch
+ "${FILESDIR}"/${PN}-2.69-perl-5.26-2.patch
)
toolchain-autoconf_src_prepare
+ eapply_user
}
diff --git a/sys-devel/autoconf/files/autoconf-2.69-perl-5.26-2.patch b/sys-devel/autoconf/files/autoconf-2.69-perl-5.26-2.patch
new file mode 100644
index 000000000000..6becf807c43e
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.69-perl-5.26-2.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/625576
+
+--- autoconf-2.69/bin/autoheader.in
++++ autoconf-2.69/bin/autoheader.in
+@@ -173,6 +173,12 @@
+ # Source what the traces are trying to tell us.
+ verb "$me: running $autoconf to trace from $ARGV[0]";
+ my $quoted_tmp = shell_quote ($tmp);
++my $perl_tmp;
++if ( $tmp =~ /^\// ) {
++ $perl_tmp=$tmp;
++} else {
++ $perl_tmp="./".$tmp;
++}
+ xsystem ("$autoconf"
+ # If you change this list, update the
+ # `Autoheader-preselections' section of autom4te.in.
+@@ -182,9 +188,9 @@
+ . " " . shell_quote ($ARGV[0]) . " >$quoted_tmp/traces.pl");
+
+ local (%verbatim, %symbol);
+-debug "$me: \`do'ing $tmp/traces.pl:\n" . `sed 's/^/| /' $quoted_tmp/traces.pl`;
+-do "$tmp/traces.pl";
+-warn "couldn't parse $tmp/traces.pl: $@" if $@;
++debug "$me: \`do'ing $perl_tmp/traces.pl:\n" . `sed 's/^/| /' $quoted_tmp/traces.pl`;
++do "$perl_tmp/traces.pl";
++warn "couldn't parse $perl_tmp/traces.pl: $@" if $@;
+ unless ($config_h)
+ {
+ error "error: AC_CONFIG_HEADERS not found in $ARGV[0]";