summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-18 15:41:41 +0200
committerSam James <sam@gentoo.org>2022-06-19 06:56:42 +0100
commit565b25decd52f93cec3282234417e37bc61d834d (patch)
treee21fb8d6ea5d795b3b9ff71e73906884499acf74
parentdev-qt/qtprintsupport: Stabilize 5.15.4-r1 x86, #851900 (diff)
downloadgentoo-565b25de.tar.gz
gentoo-565b25de.tar.bz2
gentoo-565b25de.zip
dev-java/osgi-compendium: License, HOMPAGE, SRC_URI
Closes: https://bugs.gentoo.org/852851 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild b/dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild
new file mode 100644
index 000000000000..9f45cf7b18ff
--- /dev/null
+++ b/dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Compendium API (Companion Code)"
+HOMEPAGE="https://docs.osgi.org"
+# SRC_URI="https://osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+SRC_URI="https://docs.osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+CP_DEPEND="
+ dev-java/glassfish-persistence:0
+ dev-java/osgi-core-api:0
+ dev-java/osgi-foundation:0
+ dev-java/tomcat-servlet-api:4.0"
+
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-1.8:*"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+BDEPEND="app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+src_prepare() {
+ default
+ rm -r org || die
+}