summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-09 14:57:46 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-09 15:01:50 -0700
commit56601e1b3e1a379dad813032bd2e88d12ac682cc (patch)
tree12e5f79b79ba1d4dae3b22f9ea6ede0812627b43
parentdev-perl/Pod-Abstract: EAPI bump, add missing dep (diff)
downloadgentoo-56601e1b3e1a379dad813032bd2e88d12ac682cc.tar.gz
gentoo-56601e1b3e1a379dad813032bd2e88d12ac682cc.tar.bz2
gentoo-56601e1b3e1a379dad813032bd2e88d12ac682cc.zip
dev-python/google-auth: Bump to version 1.20.1
Closes: https://bugs.gentoo.org/728460 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.20.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 111092b77ab1..16d27171dde2 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-1.0.1.tar.gz 133903 BLAKE2B 0a99dcdb37a195f24077162ea8191e2eb12aac0eec8e08d06f0b17aba9c4f5ed44f19ca41c737a249611ce02b98e03474d1e995909c5755222605e004d11fb1d SHA512 c10822c6b75700503a06a4b3a43a123d57605a043eb494bcb0232cc3941fc039d0803ed75be26d0da72fd4df613135c290fb3fdf82b0fa47d4fe0729462d80f4
DIST google-auth-1.14.3.tar.gz 101964 BLAKE2B 096768066d02248a4b614e5ea1f1035c81714ef09f6fb43fdb3ecc308d7cadaf7ad821f1dca505389fd1c73eec5e0b2d233f71f54469c43a2616f64a15661f21 SHA512 e3b76907e50b4927aaa1d450a6133943ad736427a180023ea2c4639545449769136b9db89eae54456338f1cf5bbaaa5840a8cf3db92d54f9e96407ae8935a607
+DIST google-auth-1.20.1.tar.gz 107375 BLAKE2B 2f57cd9752c46891c59ed13e2ec8c6f98e5b3cd07d329769a78872877a17580c1ff5bb9da0381ef9bd4b6b9f72f04125ef71102543cfe1dc7bc3b09a5d5d9039 SHA512 6aad44b58c71f96c686606d6e8b6f273c64ce1559737920ccc31ad761442cad7f5fab19a59daee9408b284405a00c2de769c00221ac91bcfdd48851dba6f680f
diff --git a/dev-python/google-auth/google-auth-1.20.1.ebuild b/dev-python/google-auth/google-auth-1.20.1.ebuild
new file mode 100644
index 000000000000..ce118589e344
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.20.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}