summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-30 14:56:32 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-30 14:57:14 +0200
commit5670bda2daa5d150d0638db28bd480b69daa6187 (patch)
tree3afa77c3082014642f8296b67a0910f21b504f85
parentx11-wm/treewm: EAPI7, improve ebuild (diff)
downloadgentoo-5670bda2.tar.gz
gentoo-5670bda2.tar.bz2
gentoo-5670bda2.zip
dev-libs/botan: Fix HPPA build.
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-libs/botan/botan-2.7.0.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/dev-libs/botan/botan-2.7.0.ebuild b/dev-libs/botan/botan-2.7.0.ebuild
index 9763cbe67a68..e6887c050c97 100644
--- a/dev-libs/botan/botan-2.7.0.ebuild
+++ b/dev-libs/botan/botan-2.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,8 +49,12 @@ src_configure() {
local myos=
case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ case ${CHOST} in
+ hppa*) CHOSTARCH=parisc ;;
esac
local pythonvers=()
@@ -62,25 +66,26 @@ src_configure() {
fi
CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
- --prefix="${EPREFIX}/usr" \
- --libdir=$(get_libdir) \
- --docdir=share/doc \
- --cc=gcc \
- --os=${myos} \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --without-doxygen \
+ $(use_enable static-libs static-library) \
+ $(use_with boost) \
$(use_with bzip2) \
+ $(use_with doc documentation) \
+ $(use_with doc sphinx) \
$(use_with lzma) \
$(use_with sqlite sqlite3) \
$(use_with ssl openssl) \
$(use_with zlib) \
- $(use_with boost) \
- $(use_with doc sphinx) \
- $(use_with doc documentation) \
- $(use_enable static-libs static-library) \
- --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
+ $(usex hppa --without-stack-protector '') \
+ --cc=gcc \
+ --cpu=${CHOSTARCH} \
--disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
+ --docdir=share/doc \
+ --libdir=$(get_libdir) \
+ --os=${myos} \
+ --prefix="${EPREFIX}/usr" \
+ --with-endian="$(tc-endian)" \
+ --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
+ --without-doxygen \
|| die "configure.py failed"
}