summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-10-26 07:10:13 +0000
committerSam James <sam@gentoo.org>2021-10-31 02:52:21 +0000
commit5681f9cec90421b843e08f51cd8ffa127a36c669 (patch)
treecf85fcc4815b07effeb8a939b7d28b9ad96ee185
parentwww-apps/gitea: drop vulnerable (diff)
downloadgentoo-5681f9cec90421b843e08f51cd8ffa127a36c669.tar.gz
gentoo-5681f9cec90421b843e08f51cd8ffa127a36c669.tar.bz2
gentoo-5681f9cec90421b843e08f51cd8ffa127a36c669.zip
www-apps/gitea: sync live ebuild
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22705 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-apps/gitea/gitea-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 2aa2b3da3b08..a5eec77f6034 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 2016-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,6 @@ LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
SLOT="0"
IUSE="+acct pam sqlite"
-BDEPEND=">=net-libs/nodejs-10[npm]"
COMMON_DEPEND="
acct? (
acct-group/git
@@ -36,7 +35,7 @@ DOCS=(
custom/conf/app.example.ini CONTRIBUTING.md README.md
)
FILECAPS=(
- -m 0755 cap_net_bind_service+ep usr/bin/gitea
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
)
RESTRICT="test"
@@ -86,9 +85,7 @@ src_compile() {
)
[[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")
- # -j1 as Makefile doesn't handle dependancy correctly, and is not
- # useful as golang compiler don't use this info.
- env "${makeenv[@]}" emake -j1 build
+ env "${makeenv[@]}" emake backend
}
src_install() {
@@ -118,4 +115,9 @@ src_install() {
pkg_postinst() {
fcaps_pkg_postinst
tmpfiles_process gitea.conf
+
+ ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
+ ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
+ ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
}