summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-01-30 08:15:43 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-01-30 08:16:34 +0200
commit568339e99305a1ee5dfddcecf1311020e465974f (patch)
treeda2a31373fb0697d0d30b6361fc894a77bccbe29
parentwww-client/firefox: drop 102.6.0, 108.0.2 (diff)
downloadgentoo-568339e9.tar.gz
gentoo-568339e9.tar.bz2
gentoo-568339e9.zip
media-libs/openh264: drop 2.3.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-libs/openh264/Manifest1
-rw-r--r--media-libs/openh264/openh264-2.3.0.ebuild121
2 files changed, 0 insertions, 122 deletions
diff --git a/media-libs/openh264/Manifest b/media-libs/openh264/Manifest
index 4a931d861a82..01ff57956a19 100644
--- a/media-libs/openh264/Manifest
+++ b/media-libs/openh264/Manifest
@@ -1,3 +1,2 @@
DIST gmp-api-Firefox39-3a01c086d1b0394238ff1b5ad22e76022830625a.tar.gz 10464 BLAKE2B db6990a55b4128c267ee5ffa4e38edd2551c862e549776b4092d5683818001366665830c6304642cdd9c2c0afe06035edebafde769693082ae7a5236cdc463e8 SHA512 a6383834391d98754177b54df31d006144b5cad952df60115fd12fb6f0c87e571a10f9ce7276b817e4137efd97ffa7bca5092e289b0eb7cde2a3ad923319e874
-DIST openh264-2.3.0.tar.gz 60290792 BLAKE2B 08aa571471188c72bb0f098fa1cfaf9ba46ee4311f50518de868a2d7bbd61d9d4547cf5d33b3140d56c09a1ea7ea411bfaa96ed960e159876e6cc803f081b5d3 SHA512 5f0ccbb3c0026a010d9830e973312486f9d5ea8152afa3653ab6b3c43906a1169cebea70532134c1624846cc03b586e85b12cfd0621af505bd532a7dd833defd
DIST openh264-2.3.1.tar.gz 60290897 BLAKE2B b4480150cfe7c44b89c7b294698db06f93d96f5f9f3ef4345108c4e360e99bc6133407cead54e720e6e74aa17ab9f2e4342287a42f19463a54eb44c9d3141c80 SHA512 fd59c767794cdfb934d692d5929e4500d78606cbf1e403bc7c7dce048cc07e40daa0794357adb856d29479427a53460c76338e156b6bbeaa36139afcd603c8e1
diff --git a/media-libs/openh264/openh264-2.3.0.ebuild b/media-libs/openh264/openh264-2.3.0.ebuild
deleted file mode 100644
index 25f5bca8a26d..000000000000
--- a/media-libs/openh264/openh264-2.3.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs multilib-minimal
-
-MOZVER=39
-MY_GMP_COMMIT="3a01c086d1b0394238ff1b5ad22e76022830625a"
-
-DESCRIPTION="Cisco OpenH264 library and Gecko Media Plugin for Mozilla packages"
-HOMEPAGE="https://www.openh264.org/ https://github.com/cisco/openh264"
-SRC_URI="https://github.com/cisco/openh264/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/mozilla/gmp-api/archive/${MY_GMP_COMMIT}.tar.gz -> gmp-api-Firefox${MOZVER}-${MY_GMP_COMMIT}.tar.gz"
-LICENSE="BSD"
-
-# openh264 soname version.
-# (2.2.0 needed a minor bump due to undocumented but breaking ABI changes, just to be sure.
-# https://github.com/cisco/openh264/issues/3459 )
-SLOT="0/6.1"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="cpu_flags_arm_neon cpu_flags_x86_avx2 +plugin utils"
-
-RESTRICT="bindist test"
-
-BDEPEND="
- abi_x86_32? ( dev-lang/nasm )
- abi_x86_64? ( dev-lang/nasm )"
-
-DOCS=( LICENSE CONTRIBUTORS README.md )
-
-PATCHES=( "${FILESDIR}"/openh264-2.3.0-pkgconfig-pathfix.patch )
-
-src_prepare() {
- default
-
- sed -i -e 's/ | generate-version//g' Makefile || die
- sed -e 's|$FULL_VERSION|""|g' codec/common/inc/version_gen.h.template > \
- codec/common/inc/version_gen.h
-
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ln -s "${WORKDIR}"/gmp-api-${MY_GMP_COMMIT} gmp-api || die
-}
-
-emakecmd() {
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
- emake V=Yes CFLAGS_M32="" CFLAGS_M64="" CFLAGS_OPT="" \
- PREFIX="${EPREFIX}/usr" \
- LIBDIR_NAME="$(get_libdir)" \
- SHAREDLIB_DIR="${EPREFIX}/usr/$(get_libdir)" \
- INCLUDES_DIR="${EPREFIX}/usr/include/${PN}" \
- HAVE_AVX2=$(usex cpu_flags_x86_avx2 Yes No) \
- ARCH="$(tc-arch)" \
- $@
-}
-
-multilib_src_compile() {
- local myopts="ENABLE64BIT=No"
- case "${ABI}" in
- s390x|alpha|*64) myopts="ENABLE64BIT=Yes";;
- esac
-
- if use arm; then
- myopts+=" USE_ASM=$(usex cpu_flags_arm_neon Yes No)"
- fi
-
- emakecmd ${myopts}
- use plugin && emakecmd ${myopts} plugin
-}
-
-multilib_src_install() {
- emakecmd DESTDIR="${D}" install-shared
-
- if use utils; then
- newbin h264enc openh264enc
- newbin h264dec openh264dec
- fi
-
- if use plugin; then
- local plugpath="${ROOT}/usr/$(get_libdir)/nsbrowser/plugins/gmp-gmp${PN}/system-installed"
- insinto "${plugpath}"
- doins libgmpopenh264.so* gmpopenh264.info
- echo "MOZ_GMP_PATH=\"${plugpath}\"" >"${T}"/98-moz-gmp-${PN}
- doenvd "${T}"/98-moz-gmp-${PN}
-
- cat <<PREFEOF >"${T}"/${P}.js
-pref("media.gmp-gmp${PN}.autoupdate", false);
-pref("media.gmp-gmp${PN}.version", "system-installed");
-PREFEOF
-
- insinto /usr/$(get_libdir)/firefox/defaults/pref
- newins "${T}"/${P}.js ${PN}-${PV/_p*/}.js
-
- insinto /usr/$(get_libdir)/seamonkey/defaults/pref
- newins "${T}"/${P}.js ${PN}-${PV/_p*/}.js
- fi
-}
-
-pkg_postinst() {
- if use plugin; then
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "Please restart your login session, in order for the session's environment"
- elog "to include the new MOZ_GMP_PATH variable."
- elog ""
- fi
- elog "This package attempts to override the Mozilla GMPInstaller auto-update process,"
- elog "however even if it is not successful in doing so the profile-installed plugin"
- elog "will not be used unless this package is removed. This package will take precedence"
- elog "over any gmp-gmpopenh264 that may be installed in a user's profile."
- elog ""
- fi
-
- if use utils; then
- elog "Utilities h264enc and h264dec are installed as openh264enc and openh264dec"
- elog "to avoid file collisions with media-video/h264enc"
- elog ""
- fi
-}