summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 12:58:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 13:01:03 +0100
commit569a54e916a1e70f4c4285898ae889d078c091ed (patch)
tree9ac9c25e39920f286068e4f9bf981e855766a7be
parentapp-doc/clsync-docs: Remove last-rited pkg (diff)
downloadgentoo-569a54e9.tar.gz
gentoo-569a54e9.tar.bz2
gentoo-569a54e9.zip
app-admin/clsync: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/clsync/Manifest1
-rw-r--r--app-admin/clsync/clsync-0.4.4.ebuild106
-rw-r--r--profiles/package.mask7
3 files changed, 0 insertions, 114 deletions
diff --git a/app-admin/clsync/Manifest b/app-admin/clsync/Manifest
index aa1738bbfb77..b9bb42368d70 100644
--- a/app-admin/clsync/Manifest
+++ b/app-admin/clsync/Manifest
@@ -1,2 +1 @@
-DIST clsync-0.4.4.tar.gz 268276 BLAKE2B 0027760cfdee5c4410c4cea45aae2def6498d812d2f50038993c39a33c6029722ec2dd2cfff20815a3ffd8834eb8c439059e5f1d2cc3d2cf98ecb22ed22f2322 SHA512 cdafbf43fdeafe9cb53c08e0514ef356fb5b4bbd8da2226263180e7441d222c76e6c73f847f484b3688a8672e4a85df0346c0236d8d0ed4506d209189af02dcd
DIST clsync-0.4.5.tar.gz 276096 BLAKE2B 4fa534b342a806ca691f8a65455cb800800f7a943fa3f0913a26c37d2cd0f9d762630ad01eeb80bdd0d90a0731bed5f2aa60444a654972da9479c116e0e937aa SHA512 6568f3c49ac4fe11e54593ba23eed392d0b7d9b5bf052983c4a5a2befbb807dbd3f9d13412264f8909998702f869d1cd6db77d89bd9491414b1f3213437c5212
diff --git a/app-admin/clsync/clsync-0.4.4.ebuild b/app-admin/clsync/clsync-0.4.4.ebuild
deleted file mode 100644
index 0bb2ccba5d57..000000000000
--- a/app-admin/clsync/clsync-0.4.4.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools linux-info systemd
-
-DESCRIPTION="Live sync tool based on inotify, written in GNU C"
-HOMEPAGE="https://github.com/clsync/clsync http://ut.mephi.ru/oss/clsync"
-SRC_URI="https://github.com/clsync/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+caps cluster control-socket cgroups debug extra-debug
-extra-hardened gio hardened +highload-locks +inotify mhash
-namespaces seccomp"
-
-REQUIRED_USE="
- || ( gio inotify )
- extra-debug? ( debug )
- extra-hardened? ( hardened )
- mhash? ( cluster )
- seccomp? ( caps )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- dev-libs/glib:2
- caps? ( sys-libs/libcap )
- cgroups? ( dev-libs/libcgroup )
- mhash? ( app-crypt/mhash )
-"
-RDEPEND="${DEPEND}
- ~app-doc/clsync-docs-${PV}
-"
-
-pkg_pretend() {
- use inotify && CONFIG_CHECK+=" ~INOTIFY_USER"
- use namespaces && CONFIG_CHECK="~NAMESPACES ~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
- use seccomp && CONFIG_CHECK+=" ~SECCOMP"
- check_extra_config
-}
-
-src_prepare() {
- eapply_user
- eautoreconf
-}
-
-src_configure() {
- local harden_level=0
- use hardened && harden_level=1
- use extra-hardened && harden_level=2
-
- local debug_level=0
- use debug && debug_level=1
- use extra-debug && debug_level=2
-
- econf \
- --disable-socket-library \
- --enable-clsync \
- --enable-debug=${debug_level} \
- --enable-paranoid=${harden_level} \
- --without-bsm \
- --without-kqueue \
- $(use_enable caps capabilities) \
- $(use_enable cluster) \
- $(use_enable control-socket socket) \
- $(use_enable highload-locks) \
- $(use_enable namespaces unshare) \
- $(use_enable seccomp) \
- $(use_with cgroups libcgroup) \
- $(use_with gio gio lib) \
- $(use_with inotify inotify native) \
- $(use_with mhash)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # docs go into clsync-docs
- rm -rf "${ED}/usr/share/doc" || die
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
-
- # filter rules and sync scripts are supposed to be here
- insinto /etc/${PN}
- newins "${FILESDIR}/${PN}.conf" "${PN}.conf"
- keepdir /etc/${PN}
-
- systemd_dounit "examples/clsync@.service"
-}
-
-pkg_postinst() {
- einfo "${PN} is just a convenient way to run synchronization tools on live data,"
- einfo "it doesn't copy data itself, so you need to install software to do actual"
- einfo "data transfer. Usually net-misc/rsync is a good choise, but ${PN} is"
- einfo "is flexible enough to use any user tool, see manual page for details."
- einfo
- einfo "${PN} init script can be multiplexed, to use symlink init script to"
- einfo "othername and use conf.d/othername to configure it."
- einfo
- einfo "If you're interested in improved security, enable"
- einfo "USE=\"caps cgroups hardened namespaces seccomp\""
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index bd85a2d26f14..109cef2ae6e2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -274,13 +274,6 @@ dev-ruby/rack:2.1
# Bug #762361
media-sound/takcd
-# Andrew Savchenko <bircoph@gentoo.org> (2020-12-26)
-# All docs and socket library functionality are merged back into single
-# app-admin/clsync package using USE="apidoc doc socket-library" starting
-# from clsync-0.4.5.
-# No reverse dependencies. Removal in 30 days.
-<app-admin/clsync-0.4.5
-
# Sergei Trofimovich <slyfox@gentoo.org> (2020-12-20)
# Needs a port to haskell-src-exts compatible with ghc-8.8.
# https://github.com/ndmitchell/derive/pull/37