summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:22:12 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:34 +1100
commit56ae55c8fe67336c2d66bc677fa71ff7315952a4 (patch)
tree107bbcb1e0932847a3e5cfeeffd9649d6681f97d
parentdev-ml/ppx_compare: Bump to 0.14.0 (diff)
downloadgentoo-56ae55c8fe67336c2d66bc677fa71ff7315952a4.tar.gz
gentoo-56ae55c8fe67336c2d66bc677fa71ff7315952a4.tar.bz2
gentoo-56ae55c8fe67336c2d66bc677fa71ff7315952a4.zip
dev-ml/ppx_custom_printf: Bump to 0.14.0
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
-rw-r--r--dev-ml/ppx_custom_printf/Manifest1
-rw-r--r--dev-ml/ppx_custom_printf/files/ppx_custom_printf-0.14.0-ppxlib-0.18.0.patch41
-rw-r--r--dev-ml/ppx_custom_printf/metadata.xml5
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-0.14.0.ebuild26
4 files changed, 72 insertions, 1 deletions
diff --git a/dev-ml/ppx_custom_printf/Manifest b/dev-ml/ppx_custom_printf/Manifest
index d71f4fa73f8c..910e402a2a34 100644
--- a/dev-ml/ppx_custom_printf/Manifest
+++ b/dev-ml/ppx_custom_printf/Manifest
@@ -1 +1,2 @@
+DIST ppx_custom_printf-0.14.0.tar.gz 9600 BLAKE2B 7b921188e158d59a160502b410ac780709b40fd408cf2e06a0adb70952ef3e72144deaee1c40df512cc09997ce87621e0be2a32d28e8408914fb90f3416e0532 SHA512 2f607df87aa372ef602b4aeb44a2d697ff8696001161e544398c3675280ef7af402f4b34b8cfce900791129d2a9db13ccbf4e73518f58487adc47d5188c8652c
DIST ppx_custom_printf-0.9.0.tar.gz 11527 BLAKE2B ad1791f1bad3c8583e67ca6300e98e8a7a047f723bbaa7c80cf6224f7333e7893fce7289456c39f6959089f15cc0da20106b33689ab198b1f47f6dc0bd853c77 SHA512 7608e09aac26f4f51d124d30c25a510abb73bea606007524a5563f5bb2c0e71f1ff033edb32c48f0c69656e8c3924b57186639812b1a647ce31f7ae15dc466cb
diff --git a/dev-ml/ppx_custom_printf/files/ppx_custom_printf-0.14.0-ppxlib-0.18.0.patch b/dev-ml/ppx_custom_printf/files/ppx_custom_printf-0.14.0-ppxlib-0.18.0.patch
new file mode 100644
index 000000000000..95cd58aee4cd
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/files/ppx_custom_printf-0.14.0-ppxlib-0.18.0.patch
@@ -0,0 +1,41 @@
+commit 50f8f706e868f8ebac4f2f1392365f994d674463 (HEAD, origin/upgrade-ppxlib-0.18.0)
+Author: Nathan Rebours <nathan.p.rebours@gmail.com>
+Date: Mon Oct 5 17:56:52 2020 +0200
+
+ Make ppx_custom_printf compatible with ppxlib.0.18.0
+
+ ppxlib.0.18.0 upgrades to the 4.11 AST which results in a change
+ in string constants representation. This PR makes ppx_custom_printf
+ compatible with the latest ppxlib.
+
+ You might want for the actual release of ppxlib.0.18.0 before merging
+ this!
+
+ Signed-off-by: Nathan Rebours <nathan.p.rebours@gmail.com>
+
+diff --git a/ppx_custom_printf.opam b/ppx_custom_printf.opam
+index 80ea710..1cc3d11 100644
+--- a/ppx_custom_printf.opam
++++ b/ppx_custom_printf.opam
+@@ -15,7 +15,7 @@ depends: [
+ "base" {>= "v0.14" & < "v0.15"}
+ "ppx_sexp_conv" {>= "v0.14" & < "v0.15"}
+ "dune" {>= "2.0.0"}
+- "ppxlib" {>= "0.11.0"}
++ "ppxlib" {>= "0.18.0"}
+ ]
+ synopsis: "Printf-style format-strings for user-defined string conversion"
+ description: "
+diff --git a/src/ppx_custom_printf.ml b/src/ppx_custom_printf.ml
+index 18ad7fd..e9ad8b3 100644
+--- a/src/ppx_custom_printf.ml
++++ b/src/ppx_custom_printf.ml
+@@ -264,7 +264,7 @@ let expand_format_string ~loc fmt_string =
+ let expand e =
+ match e.pexp_desc with
+ | Pexp_apply ({ pexp_attributes = ident_attrs; _ },
+- [ (Nolabel, { pexp_desc = Pexp_constant (Pconst_string (str, _))
++ [ (Nolabel, { pexp_desc = Pexp_constant (Pconst_string (str, _, _))
+ ; pexp_loc = loc; pexp_loc_stack = _
+ ; pexp_attributes = str_attrs }) ]) ->
+ assert_no_attributes ident_attrs;
diff --git a/dev-ml/ppx_custom_printf/metadata.xml b/dev-ml/ppx_custom_printf/metadata.xml
index db6f32d8ab1d..bd8c830ce5d7 100644
--- a/dev-ml/ppx_custom_printf/metadata.xml
+++ b/dev-ml/ppx_custom_printf/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<upstream>
<remote-id type="github">janestreet/ppx_custom_printf</remote-id>
</upstream>
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-0.14.0.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.14.0.ebuild
new file mode 100644
index 000000000000..7915067e7656
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.14.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="https://github.com/janestreet/ppx_custom_printf"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ppx_sexp_conv:=
+ >=dev-ml/ppxlib-0.18.0:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ppxlib-0.18.0.patch )