summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-02 23:54:06 +0000
committerSam James <sam@gentoo.org>2021-06-03 19:14:45 +0000
commit56b1782c8862e787c1c2395f39fc82e3dc6d4837 (patch)
tree2ec374456669541aa53eb20c73dc3af03f87a6a3
parentdev-db/pgbouncer: fix BadDefaultUseFlags (diff)
downloadgentoo-56b1782c8862e787c1c2395f39fc82e3dc6d4837.tar.gz
gentoo-56b1782c8862e787c1c2395f39fc82e3dc6d4837.tar.bz2
gentoo-56b1782c8862e787c1c2395f39fc82e3dc6d4837.zip
dev-db/postgresql: fix BadDefaultUseFlags
-foo in IUSE is discouraged. It is equivalent (in every meaningful case) to 'foo' but confuses parsing tools like e.g. packages.gentoo.org. Dropping '-' from these flags has no impact on the actual default behaviour. See: https://devmanual.gentoo.org/general-concepts/use-flags/index.html#iuse-defaults Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/postgresql/postgresql-9.5.25.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-9.6.21.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-9.6.22.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-db/postgresql/postgresql-9.5.25.ebuild b/dev-db/postgresql/postgresql-9.5.25.ebuild
index 5f0e320adeed..adbf87e5ed06 100644
--- a/dev-db/postgresql/postgresql-9.5.25.ebuild
+++ b/dev-db/postgresql/postgresql-9.5.25.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
IUSE="debug doc kerberos kernel_linux ldap nls pam perl
- -pg-legacytimestamp python +readline selinux +server systemd ssl
+ pg-legacytimestamp python +readline selinux +server systemd ssl
static-libs tcl threads uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/dev-db/postgresql/postgresql-9.6.21.ebuild b/dev-db/postgresql/postgresql-9.6.21.ebuild
index b6150ca0af88..e6c0c5e5df53 100644
--- a/dev-db/postgresql/postgresql-9.6.21.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.21.ebuild
@@ -21,7 +21,7 @@ DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
IUSE="debug doc kerberos kernel_linux ldap nls pam perl
- -pg-legacytimestamp python +readline selinux +server systemd ssl
+ pg-legacytimestamp python +readline selinux +server systemd ssl
static-libs tcl threads uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/dev-db/postgresql/postgresql-9.6.22.ebuild b/dev-db/postgresql/postgresql-9.6.22.ebuild
index 5c7e9f2653e2..dba0d5f7ae26 100644
--- a/dev-db/postgresql/postgresql-9.6.22.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.22.ebuild
@@ -21,7 +21,7 @@ DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
IUSE="debug doc kerberos kernel_linux ldap nls pam perl
- -pg-legacytimestamp python +readline selinux +server systemd ssl
+ pg-legacytimestamp python +readline selinux +server systemd ssl
static-libs tcl threads uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"