summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-08 08:47:04 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-04 02:50:05 -0500
commit56b9600fe85c75041ae61f0d21a8c55ffa3935c7 (patch)
tree30fce75142ca1abe29ec4e63ed8ae60d6e40428f
parentmedia-gfx/ahoviewer: stabilize 2.0.0_pre20211126 for x86 (diff)
downloadgentoo-56b9600f.tar.gz
gentoo-56b9600f.tar.bz2
gentoo-56b9600f.zip
x11-terms/kitty-shell-integration: initial import, version 0.24.0
Upstream now recommends to split kitty into three packages (kitty, kitty-terminfo, kitty-shell-integration). Go ahead and use this to match what's expected / documentation. Similarly to kitty-terminfo, this is to provide scripts on a remote machine without installing the entire terminal and its GUI dependencies. Not particularly familiar with zsh and fish, so actual users of the shells are welcome to send suggestions if anything is mishandled, albeit integration seems to work on both. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild34
-rw-r--r--x11-terms/kitty-shell-integration/metadata.xml20
3 files changed, 55 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
new file mode 100644
index 000000000000..23dfe1ff9b95
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -0,0 +1 @@
+DIST kitty-0.24.0.tar.xz 4503616 BLAKE2B 5a42b4815d25ff9e3a1f9fb6673e4e58ec3b59b5f81dc4098ef24408580d070e92a181e84167f5a343ffc3a9af33556823153d463eaa8e406f31c032ed8bab37 SHA512 b851ed56d16f9a39d47810bf27c2bc8cbb52d476376c4090045db90c1ad0bc7db6fd9e97edd6ce50a6d69e716671e1e909aab889ecac368857ad5c07f68a76af
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild
new file mode 100644
index 000000000000..fc3c61131372
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}
diff --git a/x11-terms/kitty-shell-integration/metadata.xml b/x11-terms/kitty-shell-integration/metadata.xml
new file mode 100644
index 000000000000..60597e252fe3
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>pabloorduna98@gmail.com</email>
+ <name>Pablo Orduna</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kovidgoyal/kitty</remote-id>
+ </upstream>
+</pkgmetadata>