summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-07 20:29:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-07 20:48:01 +0100
commit56c4be7f33e1067fdae407560175085906fdb81f (patch)
treef29289a27de5d86a046f6833ea75d7623f46f4e1
parentdev-python/docstring-to-markdown: Remove old (diff)
downloadgentoo-56c4be7f33e1067fdae407560175085906fdb81f.tar.gz
gentoo-56c4be7f33e1067fdae407560175085906fdb81f.tar.bz2
gentoo-56c4be7f33e1067fdae407560175085906fdb81f.zip
dev-python/pypdf: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/files/pypdf-4.0.1-pytest-8.patch80
-rw-r--r--dev-python/pypdf/pypdf-4.0.1.ebuild64
3 files changed, 0 insertions, 145 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index aa8a933a9bfa..e0577570adf9 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,3 @@
-DIST pypdf-4.0.1.gh.tar.gz 7992979 BLAKE2B a072b50d177a89133bd5c7a74cae1d4f4ed5d6bcb1d78c68573c98f792a28a8ded26b5a82743a70ec2cd41651db8a19580cc48b0376c0dfe2f422826311914c3 SHA512 e9170b75ab00ce86580194bfa64ff3a31eb6fca62adc006478fcee3a78a99df269c75857672838c2b752b78b19174883cecb2eea5586878f81eb75474fabee6d
DIST pypdf-4.0.2.gh.tar.gz 7992844 BLAKE2B ddd38e8c27230c6425de2677c1f2bd6f521c87e4b10e4791ed8d2b961c7c9e210b49b6d684780f16fb1620db7c123aed9ee548b381d54ae881a6e64305b26379 SHA512 4539f2c1c4b98e27dd3f43c7aa44efe03e80c8089f655130dd80dceee85afae235bc819b9309bc36653c953741ec3b998ccbb1274c28abf144792ae44147efd9
DIST pypdf-4.1.0.gh.tar.gz 8005929 BLAKE2B 3bec62a86dc8503a8738ea14941db6f66181784288d51f345f6d0a973e80c984c676814820ee68d7d5372931272747a22def10928f935ea7bdef2f2a5cdffd28 SHA512 1dac8f45d24406b17a6c0872fdac928b2aa8e434d64b5f8bd3359ca58f51e7a936d0990d3a7d4b4bbd433ca1497e343838ab0dbd3d22f2db32575472f1a660c9
DIST pypdf-sample-files-8c405ece5eff12396a34a1fae3276132002e1753.gh.tar.gz 11748093 BLAKE2B c5989200893b28a3c2062bb024a5cfc6f3389dc259ec129857979fa43469e1274559612b4d555499e2c7e16cf34be07825229932bf4d147fa6d7324d043e97d5 SHA512 c9771129b7668a2fd1fa79bb859ae9213f3d60341cf1b9937ff0eaab0de9bf4c35adcb7b896e93329038dc0f3809a0c697c523f8fe41b43030b0b029a88058e3
diff --git a/dev-python/pypdf/files/pypdf-4.0.1-pytest-8.patch b/dev-python/pypdf/files/pypdf-4.0.1-pytest-8.patch
deleted file mode 100644
index 16b685970b55..000000000000
--- a/dev-python/pypdf/files/pypdf-4.0.1-pytest-8.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 7fd67692faf502663c001b38e48083c68876085b Mon Sep 17 00:00:00 2001
-From: Stefan <96178532+stefan6419846@users.noreply.github.com>
-Date: Mon, 29 Jan 2024 15:43:52 +0100
-Subject: [PATCH 1/2] TST: Avoid catching not emitted warnings
-
----
- tests/test_reader.py | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/tests/test_reader.py b/tests/test_reader.py
-index 98f73a01c..ad289c296 100644
---- a/tests/test_reader.py
-+++ b/tests/test_reader.py
-@@ -335,7 +335,7 @@ def test_get_images_raw(
- )
- pdf_stream = io.BytesIO(pdf_data)
- if should_fail:
-- with pytest.raises(PdfReadError) as exc, pytest.warns(PdfReadWarning):
-+ with pytest.raises(PdfReadError) as exc:
- PdfReader(pdf_stream, strict=strict)
- assert exc.type == PdfReadError
- if startx_correction == -1:
-@@ -530,7 +530,7 @@ def test_read_prev_0_trailer():
- pdf_data.find(b"xref") - 1,
- )
- pdf_stream = io.BytesIO(pdf_data)
-- with pytest.raises(PdfReadError) as exc, pytest.warns(PdfReadWarning):
-+ with pytest.raises(PdfReadError) as exc:
- PdfReader(pdf_stream, strict=True)
- assert exc.value.args[0] == "/Prev=0 in the trailer (try opening with strict=False)"
-
-@@ -607,7 +607,7 @@ def test_read_unknown_zero_pages(caplog):
- "Xref table not zero-indexed. ID numbers for objects will be corrected.",
- ]
- assert normalize_warnings(caplog.text) == warnings
-- with pytest.raises(PdfReadError) as exc, pytest.warns(PdfReadWarning):
-+ with pytest.raises(PdfReadError) as exc:
- len(reader.pages)
-
- assert exc.value.args[0] == "Could not find object."
-@@ -617,7 +617,7 @@ def test_read_unknown_zero_pages(caplog):
- "startxref on same line as offset",
- ]
- assert normalize_warnings(caplog.text) == warnings
-- with pytest.raises(AttributeError) as exc, pytest.warns(PdfReadWarning):
-+ with pytest.raises(AttributeError) as exc:
- len(reader.pages)
- assert exc.value.args[0] == "'NoneType' object has no attribute 'get_object'"
-
-@@ -687,7 +687,7 @@ def test_issue604(caplog, strict):
- outline = None
- if strict:
- pdf = PdfReader(f, strict=strict)
-- with pytest.raises(PdfReadError) as exc, pytest.warns(PdfReadWarning):
-+ with pytest.raises(PdfReadError) as exc:
- outline = pdf.outline
- if "Unknown Destination" not in exc.value.args[0]:
- raise Exception("Expected exception not raised")
-
-From 259128c25e25e23f284267d0abb9d7f1bd932de5 Mon Sep 17 00:00:00 2001
-From: Stefan <96178532+stefan6419846@users.noreply.github.com>
-Date: Mon, 29 Jan 2024 15:46:34 +0100
-Subject: [PATCH 2/2] remove now unused import
-
----
- tests/test_reader.py | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/tests/test_reader.py b/tests/test_reader.py
-index ad289c296..c9c6be9b3 100644
---- a/tests/test_reader.py
-+++ b/tests/test_reader.py
-@@ -17,7 +17,6 @@
- EmptyFileError,
- FileNotDecryptedError,
- PdfReadError,
-- PdfReadWarning,
- WrongPasswordError,
- )
- from pypdf.generic import (
diff --git a/dev-python/pypdf/pypdf-4.0.1.ebuild b/dev-python/pypdf/pypdf-4.0.1.ebuild
deleted file mode 100644
index 9392995da2d7..000000000000
--- a/dev-python/pypdf/pypdf-4.0.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
-DESCRIPTION="Python library to work with PDF files"
-HOMEPAGE="
- https://pypi.org/project/pypdf/
- https://github.com/py-pdf/pypdf/
-"
-SRC_URI="
- https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
- -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
- )
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,zlib,${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/py-pdf/pypdf/pull/2429
- "${FILESDIR}/${P}-pytest-8.patch"
-)
-
-src_unpack() {
- default
- if use test; then
- mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- tests/test_reader.py::test_decode_permissions
- tests/test_workflows.py::test_text_extraction_layout_mode
- # rely on -Werror
- tests/test_utils.py::test_deprecate_no_replacement
- tests/test_workflows.py::test_orientations
- tests/test_writer.py::test_remove_image_per_type
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -m "not enable_socket"
-}