summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 20:28:07 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 20:28:07 +0200
commit56c87cf06e4cb1c23349dedf27704ae70a384c3a (patch)
treed84f7fc321e26c768e9e2c224f109c8af52cfb36
parentkde-misc/rsibreak: version bump (diff)
downloadgentoo-56c87cf0.tar.gz
gentoo-56c87cf0.tar.bz2
gentoo-56c87cf0.zip
x11-drivers/xf86-video-qxl: fix Xspice shebang
Bug: https://bugs.gentoo.org/show_bug.cgi?id=568868 Package-Manager: portage-2.2.28
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4-r1.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..6dd24ea7f013
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 xorg-2
+
+DESCRIPTION="QEMU QXL paravirt video driver"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="xspice"
+
+RDEPEND="xspice? (
+ app-emulation/spice
+ ${PYTHON_DEPS}
+ )
+ x11-base/xorg-server[-minimal]
+ >=x11-libs/libdrm-2.4.46"
+DEPEND="${RDEPEND}
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.12.0"
+
+src_prepare() {
+ python_fix_shebang scripts
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+ xorg-2_src_configure
+}