summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-09 03:59:05 +0000
committerSam James <sam@gentoo.org>2023-02-09 03:59:05 +0000
commit56cd32a30a93c362963c55b4499b6033be7dc0bb (patch)
tree3108d3560a74eeca9e1a89cc0038f1af65f4cee6
parentsys-apps/util-linux: backport fix for 'more' exit (diff)
downloadgentoo-56cd32a3.tar.gz
gentoo-56cd32a3.tar.bz2
gentoo-56cd32a3.zip
media-sound/vorbis-tools: fix build w/ clang 16
Closes: https://bugs.gentoo.org/871042 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/vorbis-tools/files/vorbis-tools-1.4.2-clang16.patch22
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild (renamed from media-sound/vorbis-tools/vorbis-tools-1.4.2-r1.ebuild)9
2 files changed, 28 insertions, 3 deletions
diff --git a/media-sound/vorbis-tools/files/vorbis-tools-1.4.2-clang16.patch b/media-sound/vorbis-tools/files/vorbis-tools-1.4.2-clang16.patch
new file mode 100644
index 000000000000..2d9b1158e635
--- /dev/null
+++ b/media-sound/vorbis-tools/files/vorbis-tools-1.4.2-clang16.patch
@@ -0,0 +1,22 @@
+https://gitlab.xiph.org/xiph/vorbis-tools/-/merge_requests/6
+
+From ec3a1a1de87168f575b93bc9cedcfaeb82c048a4 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Tue, 7 Feb 2023 08:48:05 +0100
+Subject: [PATCH] Fix C99 compatibility glitch in ogginfo/codec_skeleton.c
+
+Include "utf8.h" for a prototype of the utf8_decode function.
+This avoids an implicit function declaration and build issues
+with future compilers.
+--- a/ogginfo/codec_skeleton.c
++++ b/ogginfo/codec_skeleton.c
+@@ -25,6 +25,7 @@
+ #include <ogg/ogg.h>
+
+ #include "i18n.h"
++#include "utf8.h"
+
+ #include "private.h"
+
+--
+GitLab
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.4.2-r1.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild
index 94609125c5c9..88fbe65aadc1 100644
--- a/media-sound/vorbis-tools/vorbis-tools-1.4.2-r1.ebuild
+++ b/media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Tools for using the Ogg Vorbis sound file format"
HOMEPAGE="https://xiph.org/vorbis/"
@@ -29,7 +29,10 @@ BDEPEND="
nls? ( sys-devel/gettext )
"
-PATCHES=( "${FILESDIR}"/${P}-docdir.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-docdir.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
src_configure() {
local myeconfargs=(