summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-09-02 14:03:04 +0200
committerSam James <sam@gentoo.org>2023-09-24 23:07:30 +0100
commit56d1a297fe8932e6d2fb2cab47b2f0a0b1a37c27 (patch)
treea8733e163b77ff2e7fbbf9c8d4b469ad9ecc2674
parentdev-python/elasticsearch: add 8.10.0 (diff)
downloadgentoo-56d1a297.tar.gz
gentoo-56d1a297.tar.bz2
gentoo-56d1a297.zip
net-wireless/iw: add rdepend on wireless-regdb
iw can bring up a wireless device so it needs to depend on net-wireless/wireless-regdb. Fix the compile flags, so they are actually fully honored. Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32562 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-wireless/iw/iw-5.19-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-wireless/iw/iw-5.19-r1.ebuild b/net-wireless/iw/iw-5.19-r1.ebuild
new file mode 100644
index 000000000000..f1bbe2108630
--- /dev/null
+++ b/net-wireless/iw/iw-5.19-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="nl80211 configuration utility for wireless devices using the mac80211 stack"
+HOMEPAGE="https://wireless.wiki.kernel.org/en/users/Documentation/iw"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/libnl:="
+RDEPEND="
+ ${DEPEND}
+ net-wireless/wireless-regdb
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ tc-export CC LD PKG_CONFIG
+
+ # do not compress man pages by default.
+ sed 's@\(iw\.8\)\.gz@\1@' -i Makefile || die
+}
+
+src_compile() {
+ # Set flags prior so they are honored
+ CFLAGS="${CFLAGS:+${CFLAGS} }${CPPFLAGS}"
+ LDFLAGS="${CFLAGS:+${CFLAGS} }${LDFLAGS}"
+ emake V=1
+}
+
+src_install() {
+ emake V=1 DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}