summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2023-08-16 13:53:07 -0500
committerConrad Kostecki <conikost@gentoo.org>2023-08-20 00:31:02 +0200
commit56d4344bcb55d80c91c2b9316259870861e34409 (patch)
tree7275efaac1ce5d7504d3ee08187d38709d1467fd
parentdev-util/gengetopt: EAPI8 bump, fix LICENSE (diff)
downloadgentoo-56d4344bcb55d80c91c2b9316259870861e34409.tar.gz
gentoo-56d4344bcb55d80c91c2b9316259870861e34409.tar.bz2
gentoo-56d4344bcb55d80c91c2b9316259870861e34409.zip
app-crypt/swtpm: add 0.8.1
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32344 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-crypt/swtpm/Manifest1
-rw-r--r--app-crypt/swtpm/swtpm-0.8.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/swtpm/Manifest b/app-crypt/swtpm/Manifest
index 5091e8127e17..54a4961fa823 100644
--- a/app-crypt/swtpm/Manifest
+++ b/app-crypt/swtpm/Manifest
@@ -1,2 +1,3 @@
DIST swtpm-0.7.3.tar.gz 354088 BLAKE2B 687e3161cbc08be68427648187ba2fb05749bcaaf9929b951eea4884bd4210c6105a2494f5e7d51915e5be1b700b13889cd83c96d22e00d621ea9336221ee67b SHA512 7f4cdf7ca2539f28e3a78e2a081b24983f3305905c7cafcac0957b14f5c06c8ee9485a0adaf3710561091f9ee85e00822fe1ff874389808218c1e17f938c45d9
DIST swtpm-0.8.0.tar.gz 363951 BLAKE2B 8ec91961c5ac145dc5d1c3c4a609d18bc425caef0efb4d2b18c08c76acacefa619617b6e7b6e8e4e707117a29e3ff3c0198b63d81d24fc747435c6e06e48e8e9 SHA512 7f70c19f732404061be6168c96c0dd3ec91ed8b50dddcafcb50d810062ce0e83ad85360191f97db5db9dc034e01d91cebe3912449d896d2cde68fe060a0adb09
+DIST swtpm-0.8.1.tar.gz 364169 BLAKE2B 4b364ed581ea97d78c5c6248870503b1612d7d164b05b76c1f02644aade6fd09f204396f0a2d0db4e0ecec2792dc512f7c4393c44bf7ce447a3a7fbb8754594f SHA512 07276519b0e20c9c4167ce78e789d2072eb90172ed9bcba2a11eef46ee03a77860f7a2218f4dc013a2ddb8471079e3cbe43f8ab02174bd704a78aea8eee3d2fc
diff --git a/app-crypt/swtpm/swtpm-0.8.1.ebuild b/app-crypt/swtpm/swtpm-0.8.1.ebuild
new file mode 100644
index 000000000000..b4921f3d1e2b
--- /dev/null
+++ b/app-crypt/swtpm/swtpm-0.8.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="Libtpms-based TPM emulator"
+HOMEPAGE="https://github.com/stefanberger/swtpm"
+SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="fuse seccomp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="fuse? (
+ dev-libs/glib:2
+ sys-fs/fuse:0
+ )
+ seccomp? ( sys-libs/libseccomp )
+ dev-libs/libtasn1:=
+ acct-group/tss
+ acct-user/tss
+ dev-libs/openssl:0=
+ dev-libs/json-glib
+ dev-libs/libtpms"
+
+DEPEND="${RDEPEND}
+ test? (
+ net-misc/socat
+ dev-tcltk/expect
+ )"
+
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.0-fix-localca-path.patch"
+ "${FILESDIR}/${PN}-0.5.0-build-sys-Remove-WError.patch"
+ "${FILESDIR}/${PN}-0.7.2-Conditionalize-test-dependencies.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl \
+ --without-selinux \
+ $(use_with fuse cuse) \
+ $(use_with seccomp) \
+ $(use_enable test)
+}
+
+src_install() {
+ default
+ fowners -R tss:root /var/lib/swtpm-localca
+ fperms 750 /var/lib/swtpm-localca
+ keepdir /var/lib/swtpm-localca
+ find "${D}" -name '*.la' -delete || die
+}